Opened 13 days ago

Closed 11 days ago

#60723 closed defect (fixed)

sqlitebrowser crashes immediately on launch

Reported by: amake (Aaron Madlon-Kay) Owned by: i0ntempest
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: sqlitebrowser

Description

sqlitebrowser installs fine but crashes immediately upon launch. Running from the Terminal I find the following error message:

% /Applications/MacPorts/DB\ Browser\ for\ SQLite.app/Contents/MacOS/DB\ Browser\ for\ SQLite
dyld: Library not loaded: @rpath/libqscintilla2_qt5.15.dylib
  Referenced from: /Applications/MacPorts/DB Browser for SQLite.app/Contents/MacOS/DB Browser for SQLite
  Reason: image not found

Attachments (1)

main.log (750.6 KB) - added by amake (Aaron Madlon-Kay) 13 days ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 days ago by amake (Aaron Madlon-Kay)

Summary: sqlitebrowser doesn't runsqlitebrowser crashes immediately on launch

comment:2 Changed 13 days ago by i0ntempest

That library file should have been linked using an absolute path. What's your OS version and can I have the build log?

Changed 13 days ago by amake (Aaron Madlon-Kay)

Attachment: main.log added

comment:3 Changed 13 days ago by amake (Aaron Madlon-Kay)

Sure. Thanks for taking a look.

macOS 10.15.5 19F101
Xcode 11.5 11E608c

comment:4 Changed 13 days ago by i0ntempest

Didn't find anything out of ordinary. Can you run otool -L on the executable to see the linked library paths? And put the output here please.

comment:5 Changed 12 days ago by mf2k (Frank Schima)

Cc: i0ntempest removed
Owner: set to i0ntempest
Status: newassigned

comment:6 Changed 12 days ago by amake (Aaron Madlon-Kay)

Here's the output of otool -L:

% otool -L /Applications/MacPorts/DB\ Browser\ for\ SQLite.app/Contents/MacOS/DB\ Browser\ for\ SQLite
/Applications/MacPorts/DB Browser for SQLite.app/Contents/MacOS/DB Browser for SQLite:
	/opt/local/lib/libsqlite3.0.dylib (compatibility version 9.0.0, current version 9.6.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1281.100.1)
	/System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 162.0.0)
	@rpath/libqscintilla2_qt5.15.dylib (compatibility version 15.0.0, current version 15.0.0)
	/opt/local/libexec/qt5/lib/QtPrintSupport.framework/Versions/5/QtPrintSupport (compatibility version 5.14.0, current version 5.14.2)
	/opt/local/libexec/qt5/lib/QtOpenGL.framework/Versions/5/QtOpenGL (compatibility version 5.14.0, current version 5.14.2)
	/opt/local/libexec/qt5/lib/QtWidgets.framework/Versions/5/QtWidgets (compatibility version 5.14.0, current version 5.14.2)
	/opt/local/libexec/qt5/lib/QtMacExtras.framework/Versions/5/QtMacExtras (compatibility version 5.14.0, current version 5.14.2)
	/opt/local/libexec/qt5/lib/QtGui.framework/Versions/5/QtGui (compatibility version 5.14.0, current version 5.14.2)
	/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1894.40.150)
	/System/Library/Frameworks/Metal.framework/Versions/A/Metal (compatibility version 1.0.0, current version 212.5.15)
	/opt/local/libexec/qt5/lib/QtNetwork.framework/Versions/5/QtNetwork (compatibility version 5.14.0, current version 5.14.2)
	/opt/local/libexec/qt5/lib/QtConcurrent.framework/Versions/5/QtConcurrent (compatibility version 5.14.0, current version 5.14.2)
	/opt/local/libexec/qt5/lib/QtXml.framework/Versions/5/QtXml (compatibility version 5.14.0, current version 5.14.2)
	/opt/local/libexec/qt5/lib/QtCore.framework/Versions/5/QtCore (compatibility version 5.14.0, current version 5.14.2)
	/System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration (compatibility version 1.0.0, current version 1.0.0)
	/System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility version 1.0.0, current version 275.0.0)
	/System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL (compatibility version 1.0.0, current version 1.0.0)
	/System/Library/Frameworks/AGL.framework/Versions/A/AGL (compatibility version 1.0.0, current version 1.0.0)
	/usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 902.1.0)

comment:7 Changed 11 days ago by i0ntempest

I don't know why but seems it's caused by the newest qscintilla2_qt5. Version 2.11.2 is linked with an absolute path during build.

comment:9 Changed 11 days ago by ryandesign (Ryan Schmidt)

Keywords: haspatch added

comment:10 Changed 11 days ago by i0ntempest

Resolution: fixed
Status: assignedclosed

In dfdcaa2526bad842179bba61ca6309b73fcbcb4e/macports-ports (master):

sqlitebrowser: fix lib not found for qscintilla 2.11.5

Closes: #60723

Note: See TracTickets for help on using tickets.