Opened 6 months ago

Closed 4 months ago

#61845 closed defect (fixed)

shibboleth port not building on at least Big Sur

Reported by: scantor (Scott Cantor) Owned by: scantor (Scott Cantor)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: shibboleth

Description

The port has been failing for a bit now, and some recent fixes to the Apache module flags aren't helping. Something's changed in the linker step and it's failing to link because a lot of Apache symbols aren't defined, but that's normal/expected for a module since those symbols are inside httpd itself, so you don't include that in the link line.

I don't know if this is only breaking on Big Sur, but that's distinctly possible. I have another Mac to test on that I haven't tried yet.

Change History (5)

comment:1 Changed 6 months ago by scantor (Scott Cantor)

The port does seem to build on older macOS, so it's something new in Big Sur and/or the latest toolchain.

comment:2 Changed 4 months ago by scantor (Scott Cantor)

I believe this is quite likely due to something causing the -undefined ld option to be left unset. My CLI build must be getting it set to dynamic_lookup. I suspect the problem is that Apple's libtool knows to do this and GNU libtool from macports does not. Perhaps there's a standard way to divert to Apple's?

comment:4 Changed 4 months ago by scantor (Scott Cantor)

Thanks, appreciate the links.

comment:5 Changed 4 months ago by scantor (Scott Cantor)

Resolution: fixed
Status: assignedclosed

Adding an autoreconf to the port fixed it. I suspect it just happened to get built originally ahead of a change to the port of libtool to add the flag.

Note: See TracTickets for help on using tickets.