Opened 5 months ago

Last modified 5 months ago

#62087 assigned defect

wxWidgets-3.2 @3.1.4_1 failed to configure in macosx 10.7.5 (Lion)

Reported by: YesNo801 Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc:
Port: wxWidgets-3.2

Description (last modified by mojca (Mojca Miklavec))

$ sudo port install wxWidgets-3.2
--->  Computing dependencies for wxWidgets-3.2
--->  Fetching archive for wxWidgets-3.2
--->  Attempting to fetch wxWidgets-3.2-3.1.4_1.darwin_11.x86_64.tbz2 from https://packages.macports.org/wxWidgets-3.2
--->  Attempting to fetch wxWidgets-3.2-3.1.4_1.darwin_11.x86_64.tbz2 from http://cph.dk.packages.macports.org/wxWidgets-3.2
--->  Attempting to fetch wxWidgets-3.2-3.1.4_1.darwin_11.x86_64.tbz2 from http://lil.fr.packages.macports.org/wxWidgets-3.2
--->  Fetching distfiles for wxWidgets-3.2
--->  Verifying checksums for wxWidgets-3.2
--->  Extracting wxWidgets-3.2
--->  Applying patches to wxWidgets-3.2
--->  Configuring wxWidgets-3.2
Error: Failed to configure wxWidgets-3.2, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_wxWidgets-3.2/wxWidgets-3.2/work/wxWidgets-3.1.4/build/config.log
Error: Failed to configure wxWidgets-3.2: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_wxWidgets-3.2/wxWidgets-3.2/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port wxWidgets-3.2 failed

Attachments (2)

wxWidgets-3.2-main.log (72.9 KB) - added by YesNo801 5 months ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_wxWidgets-3.2/wxWidgets-3.2/main.log
wxWidgets-3.1.4-build-config.log (47.9 KB) - added by YesNo801 5 months ago.
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_wxWidgets-3.2/wxWidgets-3.2/work/wxWidgets-3.1.4/build/config.log

Download all attachments as: .zip

Change History (6)

Changed 5 months ago by YesNo801

Attachment: wxWidgets-3.2-main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_wxWidgets-3.2/wxWidgets-3.2/main.log

Changed 5 months ago by YesNo801

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_wxWidgets-3.2/wxWidgets-3.2/work/wxWidgets-3.1.4/build/config.log

comment:1 Changed 5 months ago by mojca (Mojca Miklavec)

Description: modified (diff)

For all I know wxWidgets 3.2 dropped support for Lion, so the best we can do is fail even earlier than during configure.

The error log suggests a potentially different problem (I didn't parse the config.log yet), but their changes.txt says

Under macOS, 10.11 SDK is the minimum SDK, building and deploying under 10.10.5 and
  higher is supported, you must use at least Xcode 7.2.1.
Last edited 5 months ago by mojca (Mojca Miklavec) (previous) (diff)

comment:2 Changed 5 months ago by mf2k (Frank Schima)

Cc: mojca@… removed
Owner: set to mojca
Status: newassigned

comment:3 Changed 5 months ago by kencu (Ken)

These blockers are rarely accurate with respect to MacPort's capabilities, but somebody needs to dig into the guts and figure it out.

comment:4 Changed 5 months ago by YesNo801

Hi,

Contrary to what is now being said about wxWidgets-3.2, the previous minor version @3.1.3 installs very well in Lion 10.7.5. Unfortunately, this version has disappeared from the archive and has been replaced with minor @3.1.4, which is said to no longer work from 10.10 onwards. There are several programs that depend on wxWidgets-3.2 that no longer work due to a minor version. What is the way to use wxWidgets-3.2 @ 3.1.3 that works in Lion 10.7.5? Thanks,

Note: See TracTickets for help on using tickets.