Opened 3 months ago

Closed 3 months ago

#62169 closed defect (duplicate)

mod_perl2 +perl5_30 build failure

Reported by: murrayE Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.99
Keywords: Cc:
Port: mod_perl2

Description

In order to get p5.30-libapreq2 installed -- using MacPorts 2.6.99 and lowering max_hosts_pings from default 50 to 30, I have to first install mod_perl2+perl5_30.

But installing mod_perl2+perl5_30 has build failure. Here are possibly relevant portions of main.log:

:info:build In file included from modperl_log.c:17:
:info:build In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_mod_perl2/mod_perl2/work/mod_perl-2.0.11/src/modules/perl/modperl_log.h:20:
:info:build In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_mod_perl2/mod_perl2/work/mod_perl-2.0.11/src/modules/perl/modperl_common_log.h:33:
:info:build In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_mod_perl2/mod_perl2/work/mod_perl-2.0.11/src/modules/perl/modperl_apr_includes.h:26:
:info:build In file included from /opt/local/include/apr-1/apr_version.h:130:
:info:build /opt/local/include/apr-1/apr.h:165:10: fatal error: 'sys/types.h' file not found
:info:build #include <sys/types.h>
:info:build          ^~~~~~~~~~~~~
:info:build In file included from /opt/local/include/apache2/ap_hooks.hIn file included from In file included from /opt/local/include/apache2/ap_hooks.h10/opt/local/include/apache2/ap_config.h:/opt/local/include/apache2/ap_hooks.h::In file included from In file included from  39In file included from :In file included from /opt/local/include/apache2/httpd.h:
:info:build /opt/local/include/apache2/ap_hooks.h:fatal error:252525/opt/local/include/apr-1/apr.h39:
:info:build /opt/local/include/apache2/httpd.hIn file included from ::::
:info:build 39/opt/local/include/apache2/ap_hooks.hIn file included from :
:info:build : 165'sys/types.h' file not found/opt/local/include/apache2/ap_hooks.h44:
:info:build 39:/opt/local/include/apache2/ap_hooks.h:
:info:build :
:info:build 39In file included from :
:info:build :
:info:build /opt/local/include/apr-1/apr.h:
:info:build :
:info:build 3944/opt/local/include/apache2/ap_hooks.h/opt/local/include/apr-1/apr.h/opt/local/include/apr-1/apr.h::165:In file included from :/opt/local/include/apr-1/apr.h165:::165:In file included from 16510::101039 :::
:info:build  #include <sys/types.h>/opt/local/include/apache2/ap_config.h::3910fatal error

Attachments (1)

main.log (84.5 KB) - added by murrayE 3 months ago.
main.log

Download all attachments as: .zip

Change History (4)

Changed 3 months ago by murrayE

Attachment: main.log added

main.log

comment:1 Changed 3 months ago by murrayE

Port: mod_perl2 added
Priority: NormalHigh
Version: 2.6.99

I don't see where to add CC to maintainer. How do it?

comment:2 in reply to:  1 Changed 3 months ago by reneeotten (Renee Otten)

Priority: HighNormal

Replying to murrayE:

I don't see where to add CC to maintainer. How do it?

% port info --maintainer mod_perl2
maintainer:

the port is not maintained, so there is nothing you can/have to do more.

comment:3 Changed 3 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #61321.

Note: See TracTickets for help on using tickets.