Opened 3 months ago

Closed 3 months ago

Last modified 13 days ago

#62821 closed defect (worksforme)

aom - Git Clone Failed

Reported by: RobK88 Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc: mcalhoun@…
Port: aom

Description

Unable to upgrade aom. Git clone failed.

$ sudo port upgrade aom
--->  Computing dependencies for aom
--->  Fetching distfiles for aom
Error: Failed to fetch aom: Git clone failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_aom/aom/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Change History (4)

comment:1 Changed 3 months ago by RobK88

Please close the ticket.

I was able to get around the "Git clone failed" error by disabling my secure proxy. For some reason Macports has problems with proxies when it tries to perform a git clone.

comment:2 Changed 3 months ago by kencu (Ken)

Resolution: worksforme
Status: newclosed

comment:3 Changed 13 days ago by opoplawski (Orion Poplawski)

It would be good to find a proper way to deal with this issue. I suspect the issue is that the https_proxy environment variable is not being passed to the build script - though I'm not sure why this would be. I've configured sudo to pass the proxy variables and most builds work fine - just not aom which does this extra git clone in its configure script.

comment:4 Changed 13 days ago by opoplawski (Orion Poplawski)

After poking in the macports code - it appears to expect the variable HTTPS_PROXY rather than https_proxy. Setting that and adding that to the sudo keep env settings seems to have resolved the issue for me.

Note: See TracTickets for help on using tickets.