#66311 closed defect (fixed)

splint @3.1.2: fatal error: 'signature.tab.h' file not found

Reported by: sudheerhebbale (Sudheer Hebbale) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: bigsur monterey ventura Cc: ballapete (Peter "Pete" Dyballa)
Port: splint

Description (last modified by ryandesign (Ryan Carsten Schmidt))

Hi,

While upgrading the installation of splint on the new version of osX (13.0.1).

Build fails while compiling a file signature.c, for being unable to include signature.tab.h

The following is the log generated

org_macports_release_tarballs_ports_devel_splint/splint/work/splint-3.1.2'
:info:build Making all in src
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_splint/splint/work/splint-3.1.2/src'
:info:build Compiling signature.c...
:info:build signature.c:181:10: fatal error: 'signature.tab.h' file not found
:info:build #include "signature.tab.h"
:info:build          ^~~~~~~~~~~~~~~~~
:info:build 1 error generated.
:info:build make[2]: *** [signature.o] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_splint/splint/work/splint-3.1.2/src'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_splint/splint/work/splint-3.1.2'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_splint/splint/work/splint-3.1.2'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_splint/splint/work/splint-3.1.2" && /usr/bin/make -j1 -w all
:info:build Exit code: 2
:error:build Failed to build splint: command execution failed
:debug:build Error code: CHILDSTATUS 3696 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$callback {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec -callback portprogress::target_progress_callback build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_splint/splint/main.log for details.

Attachments (2)

main.log (35.9 KB) - added by sudheerhebbale (Sudheer Hebbale) 16 months ago.
splint.log (72.7 KB) - added by kencu (Ken) 14 months ago.
log of successful build, Ventura arm64

Download all attachments as: .zip

Change History (5)

Changed 16 months ago by sudheerhebbale (Sudheer Hebbale)

Attachment: main.log added

comment:1 Changed 16 months ago by ryandesign (Ryan Carsten Schmidt)

Cc: ballapete added
Description: modified (diff)
Keywords: bigsur monterey ventura added; splint removed
Summary: splint is failing to build on macOS 13.0.1splint @3.1.2: fatal error: 'signature.tab.h' file not found

This was previously reported in comment:ticket:22393:3 but let's keep this ticket open to track it instead since that old ticket was originally about a different error message.

comment:2 Changed 14 months ago by kencu (Ken)

I can't reproduce this. splint installs easily on Ventura arm64 without issue:

sudo port -f deactivate active
sudo port -v -N install splint

... 

% port -v installed splint
The following ports are currently installed:
  splint @3.1.2_0 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-29T15:09:05-0800'

% port -v installed | grep active
  flex @2.6.4_0 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-25T21:20:11-0800'
  gettext @0.21_0 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-25T19:25:28-0800'
  gettext-runtime @0.21_0 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-25T19:19:55-0800'
  gettext-tools-libs @0.21_0 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-25T19:23:20-0800'
  libiconv @1.17_0 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-25T19:19:19-0800'
  libtextstyle @0.21_0 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-25T19:21:08-0800'
  m4 @1.4.19_1 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-25T19:26:57-0800'
  ncurses @6.3_0 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-25T19:20:28-0800'
  splint @3.1.2_0 (active) requested_variants='' platform='darwin 22' archs='arm64' date='2022-12-29T15:09:05-0800'

Changed 14 months ago by kencu (Ken)

Attachment: splint.log added

log of successful build, Ventura arm64

comment:3 Changed 14 months ago by kencu (Ken)

Resolution: fixed
Status: newclosed

I installed MacPorts' version of flex, in case it was conflicting, but splint still builds through without any issues.

closing as fixed, therefore. Please reopen with new information if this still fails for you.

Note: See TracTickets for help on using tickets.