#66732 closed defect (fixed)

gdb @12.1.0 needs to update its gettext dependencies

Reported by: yiorgb Owned by: kencu (Ken)
Priority: Normal Milestone:
Component: ports Version: 2.8.0
Keywords: Cc:
Port: gdb

Description

I installed macports without any issues this past summer.

Today I tried to update.

port selfupdate worked without issues. But port upgrade outdatedfailed at gdb @12.1

My OSX is up-to-date Xcode command line is installed and up-to-date

It seems that ports is trying to install the x86 version of gdb on my M1. Log file attached..

Attachments (1)

main.log (427.4 KB) - added by yiorgb 15 months ago.
log file

Download all attachments as: .zip

Change History (5)

Changed 15 months ago by yiorgb

Attachment: main.log added

log file

comment:1 Changed 15 months ago by kencu (Ken)

gdb doesn't yet work as arm64, so x86_64 is all you can have on an M1 Mac.

If that is still of use to you, then this file:

/opt/local/lib/libintl.dylib

needs to be built as universal. I guess it was picked up during the build, but may not be listed in the deps of gdb, I'll have to check.

This should fix you up:

sudo port  -f deactivate gettext-runtime
sudo port -v install gettext-runtime +universal

and then:

sudo port clean gdb
sudo port -v install gdb

comment:2 Changed 15 months ago by yiorgb

Thank you for your prompt response. I followed your suggestion and it fixed the problem! After the fix, port update outdated worked without any problems.

Last edited 15 months ago by yiorgb (previous) (diff)

comment:3 Changed 15 months ago by jmroot (Joshua Root)

Keywords: gdb arm64 removed
Summary: gdb @12.1.0 fails to build on Monterey 12.6.2 on M1 Maxgdb @12.1.0 needs to update its gettext dependencies
Type: updatedefect

The gettext port was split up into several subports a while ago. gettext itself provides executables and is usually only needed at build time. It sets installs_libs no indicating that its architectures are not required to match those of its dependents. gettext-runtime provides libintl and should usually be in depends_lib if used.

comment:4 Changed 14 months ago by kencu (Ken)

Owner: set to kencu
Resolution: fixed
Status: newclosed

In a6d1359243343571cd6a672f1bab4ea0dfe7fe6e/macports-ports (master):

gdb: uses gettext-runtime

not gettext.

closes: #66732

Note: See TracTickets for help on using tickets.