Opened 15 years ago

Closed 14 years ago

#7311 closed defect (invalid)

mysql ports fail to install on 10.4 - SQL syntax error symptom

Reported by: rod_gilchrist@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…
Port:

Description

mysql4 port fails to install (similar problems on mysql and mysql5 ports also).

Some initial permissions problems that can be fixed with:

chown mysql /opt/local/var/db/mysql chown mysql /opt/local/var/run/mysqld chown mysql /opt/local/var/log/mysql

Then initial database set up with 'mysql_install_db' fails with error:

ERROR: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near at line 1

The problem is that multi-line SQL commands give this error when read by mysqld in --bootstrap mode (they work correctly through mysql front end though).

I notice www.mysql.com has three powerPC version dmg's listed - 10.3, 10.4 and 10.4 64 bit. The 10.4 one works for me on 10.4.4.

I suspect the problem is with gcc 4.0 which gives 10.4 64 bit capability at the cost of making some things fail to compile (net-snmp is a good example). 10.3 uses gcc 3.3.

Change History (3)

comment:1 Changed 15 years ago by jberry@…

I'm assuming this bug applies only to mysql4. If there is a distinct bug for mysql5, please file a distinct bug report.

comment:2 Changed 14 years ago by markd@…

Cc: markd@… added

Have subsequent MySQL updates fixed this?

comment:3 Changed 14 years ago by markd@…

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.