Opened 15 years ago

Closed 14 years ago

#7832 closed defect (fixed)

BUG: gettex-0.14.3 fails to build when DP's emacs is not installed

Reported by: IT@… Owned by: mij@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…, bhanafee@…
Port:

Description

When trying to install gettext the build fails when make attempts to byte-compile the lisp files if emacs is not installed. I bypassed this by setting ELCFILES equal to nothing in gettext-tools/misc/Makefile but I have since read that a better fix would be to use lisp_DATA instead of lisp_LISP in gettext-tools/misc/Makefile.in.

I marked this a "major" because many ports depend on gettext...

Change History (6)

comment:1 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to mij@…
Summary: gettext fails to build when emacs is not installedBUG: gettext fails to build when emacs is not installed

comment:2 Changed 15 years ago by bhanafee@…

Cc: bhanafee@… added

comment:3 Changed 15 years ago by markd@…

Cc: markd@… added

Could you clarify the problem here? It looks like you don't mean exactly what the summary says since gettext does install without emacs. Also, provide versions.

comment:4 Changed 15 years ago by markd@…

Summary: BUG: gettext fails to build when emacs is not installedBUG: gettex-0.14.3 fails to build when DP's emacs is not installed

Oh I see. In gettext's configure.env there is: EMACS=/usr/bin/emacs. It was found to be necessary for gettext version 0.14.3 and added for bug 2826.

Can someone comment on whether this is still necessary in the latest gettext 0.14.6? Or if so is there a good workaround to the current problem?

comment:5 Changed 15 years ago by IT@…

see this link for more info on what my initial comments referred to: http://www.ugcs.caltech.edu/manuals/devtool/automake-1.9.6/automake_94.html

The initial problem appeared when I replaced emacs with a wrapper script that invoked nano instead (long story...) because the gettext build tries to byte-compile some included lisp files. My understanding of the above link is that the problem can be avoided by specifying that the lisp files not be byte-compiled by using lisp_DATA in place of lisp_LISP ... sorry I wasn't more clear before - I hope this helps... :-)

comment:6 Changed 14 years ago by markd@…

Resolution: fixed
Status: newclosed

Gettext no longer references emacs in configure.env. Closing.

Note: See TracTickets for help on using tickets.