Opened 15 years ago

Closed 15 years ago

#7929 closed defect (invalid)

Change auctex deps to include emacs-devel

Reported by: mds@… Owned by: gwright@…
Priority: Normal Milestone:
Component: base Version: 1.2
Keywords: Cc:
Port:

Description

Given the problems with the emacs port, the current workaround is to use the emacs-devel port, however auctex only recognizes the emacs port, and not emacs-devel. It's possible to "fool" auctex by installing emacs, then auctex, then uninstalling emacs and installing emacs-devel, however port -a upgrade will try (and fail) to install emacs to satisfy this dependency.

Change History (3)

comment:1 Changed 15 years ago by gwright@…

Owner: changed from darwinports-bugs@… to gwright@…

Michael,

The +devel variant for auctex was made just for this case. Have you tried that? It builds with emacs-devel as a dependency instead of emacs.

Greg

comment:2 Changed 15 years ago by mds@…

(In reply to comment #1)

Michael,

The +devel variant for auctex was made just for this case. Have you tried that? It builds with emacs-devel as a dependency instead of emacs.

Good grief. And I can even see the bit in my terminal window scrollback where I did a 'variants' to check that, and the devel variant is listed there.

Feel free to close this one with 'user error'....

-Mike

comment:3 Changed 15 years ago by gwright@…

Resolution: invalid
Status: newclosed

Hi Michael,

No problem. Let me know if you have any problems with the +devel variant.

Best Wishes, Greg

Note: See TracTickets for help on using tickets.