New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #15609 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

gnumeric build stopped at p5-getopt-long

Reported by: macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: Ricardo.Cordeiro@…
Port:

Description

gnumeric failed to build on a fresh and updated macports installation. First it stoppet at p5-hashlib (see Ticket #15607) and p5-libxml2 (see Ticket #15608), then it stopped at p5-getopt-long:

--->  Activating p5-getopt-long 2.37_0
Error: Target org.macports.activate returned: Image error: /opt/local/lib/perl5/5.8.8/Getopt/Long.pm is being used by the active perl5.8 port.  Please deactivate this port first, or use the -f flag to force the activation.
Error: The following dependencies failed to build: goffice libgnomeprintui gnome-icon-theme icon-naming-utils p5-getopt-long p5-xml-simple p5-xml-namespacesupport p5-xml-sax gtk2 atk cairo fontconfig freetype libpixman libpng render xrender jpeg pango Xft2 xorg-xproto xorg-util-macros shared-mime-info tiff libgnomecanvas gail libart_lgpl libglade2 libgnomeprint bison libgnomecups popt libgsf gnome-vfs desktop-file-utils gconf orbit2 libidl gnome-mime-data libbonobo pcre py25-gtk py25-cairo py25-numpy fftw-3
Error: Status 1 encountered during processing.

The build could continue when force-activating p5-getopt-long:

kollaps:~ henrik$ sudo /opt/local/bin/port activate -f p5-getopt-long@2.37_0
--->  Activating p5-getopt-long 2.37_0
Warning: File /opt/local/lib/perl5/5.8.8/Getopt/Long.pm already exists.  Moving to: /opt/local/lib/perl5/5.8.8/Getopt/Long.pm.mp_1213465625.
Warning: File /opt/local/lib/perl5/5.8.8/newgetopt.pl already exists.  Moving to: /opt/local/lib/perl5/5.8.8/newgetopt.pl.mp_1213465625.

Change History

comment:1 Changed 6 years ago by macports@…

I forgot to mention that this is on a Macbook Pro 2ghz with Leopard 10.5.3.

comment:2 Changed 6 years ago by macports@…

With the workarounds in #15607, #15608, #15609 (this issue) and #15612, gnumeric finally built and installed successfully.

comment:3 Changed 6 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #12875.

comment:4 Changed 6 years ago by Ricardo.Cordeiro@…

  • Cc Ricardo.Cordeiro@… added

Cc Me!

Note: See TracTickets for help on using tickets.