Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#21665 closed defect (wontfix)

gcc42 fails to build on Snow Leopard

Reported by: avs@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: snowleopard Cc: holt.bg@…, patrickrose@…, freeed@…, th-dev@…, nicholas.d.pate@…, admsimat@…, andy@…, glen@…, jamal@…, thomas.lohschmidt@…, bulk@…, widenflycht@…, leingang, macports@…, randalla@…, zahanm@…, adambair@…, florian.feldhaus@…, jknockaert@…, andreas.wilm@…, matteo.corti@…, sverek@…, roland@…, 81joe81@…, calsaiwing@…, electronjunction-misc@…, lopusz@…, aitor.roncal@…, macports@…, takashi@…, edwincheese@…, enrique.fernandez.perdomo@…, roland@…, henx@…, someuser12, krissen, chg5w@…, b.gagnon@…, kazuom@…, cooljeanius (Eric Gallager)
Port: gcc42

Description

I am trying to install pdftk (which depends on gcc42) on Snow Leopard 10.6.1, MacPorts 1.8.0. I've run port selfupdate. gcc42 build fails as follows:

/usr/bin/ranlib: file: .libs/libgfortran.a(_conjg_c16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_aint_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_anint_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_sign_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_dim_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_atan2_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_mod_r16.o) has no symbols
creating libgfortran.la
(cd .libs && rm -f libgfortran.la && ln -s ../libgfortran.la libgfortran.la)
make: *** [all] Error 2

    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for gcc42): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: The following dependencies failed to build: gcc42
Error: Status 1 encountered during processing.

Full log with debug switch turned on should be attached to this ticket.

Attachments (2)

debug.gz (138.9 KB) - added by avs@… 11 years ago.
Debug output of sudo port install pdftk
gcc42-r57804-10.6.1-ryandesign.txt.bz2 (71.3 KB) - added by ryandesign (Ryan Schmidt) 11 years ago.
debug output with parallel build disabled

Download all attachments as: .zip

Change History (62)

Changed 11 years ago by avs@…

Attachment: debug.gz added

Debug output of sudo port install pdftk

comment:1 Changed 11 years ago by avs@…

Also discussed on http://www.nabble.com/Install-fails-for-gcc42---libgfortran.a-has-no-symbols-!-td25593791.html but couldn't find a ticket for this, if this is a duplicate, my apologies.

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to mww@…
Port: gcc42 added

comment:3 Changed 11 years ago by jmroot (Joshua Root)

Cc: ryandesign@… added

Might want to give pdftk the option of building with newer gcc versions.

comment:4 in reply to:  3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed

Replying to jmr@…:

Might want to give pdftk the option of building with newer gcc versions.

See #15420.

Changed 11 years ago by ryandesign (Ryan Schmidt)

debug output with parallel build disabled

comment:5 Changed 11 years ago by ryandesign (Ryan Schmidt)

Here's my build output, which looks about the same. I turned off parallel building ("sudo port -d install gcc42 build.jobs=1") to make the failure easier to see.

comment:6 Changed 11 years ago by holt.bg@…

Cc: holt.bg@… added

Cc Me!

comment:7 Changed 11 years ago by patrickrose@…

Cc: patrickrose@… added

Cc Me!

comment:8 Changed 11 years ago by freeed@…

Cc: freeed@… added

Cc Me!

comment:9 Changed 11 years ago by th-dev@…

Cc: th-dev@… added

Cc Me!

comment:10 Changed 11 years ago by nicholas.d.pate@…

Cc: nicholas.d.pate@… added

Cc Me!

comment:11 Changed 11 years ago by admsimat@…

Cc: admsimat@… added

Cc Me!

comment:12 Changed 11 years ago by andy@…

Cc: andy@… added

Cc Me!

comment:13 Changed 11 years ago by glen@…

Cc me please

comment:14 Changed 11 years ago by glen@…

Cc: glen@… added

Cc Me!

comment:15 Changed 11 years ago by jamal@…

Cc: jamal@… added

Cc Me!

comment:16 Changed 11 years ago by jamal@…

I had installed pdftk on Leopard and then upgraded to Snow Leopard. It kept working. I only ran into trouble when I tried to reinstall all my ports. So, is there a way to get a precompiled version of pdftk?

comment:17 Changed 11 years ago by thomas.lohschmidt@…

Cc: thomas.lohschmidt@… added

Cc Me!

comment:18 in reply to:  description Changed 11 years ago by bulk@…

MacPorts 1.8.2 installed, same error whilst trying to build gcc42

comment:19 Changed 11 years ago by bulk@…

Cc: bulk@… added

Cc Me!

comment:20 Changed 11 years ago by vegardjo@…

cc me too!

comment:21 Changed 11 years ago by widenflycht@…

Cc: widenflycht@… added

Cc Me!

comment:22 Changed 11 years ago by leingang

Cc: mleingang@… added

Cc Me!

comment:23 Changed 11 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:24 Changed 11 years ago by randalla@…

Cc: randalla@… added

Cc Me!

comment:25 Changed 11 years ago by MartinBuchmann (Martin Buchmann)

Cc: Martin.Buchmann@… added

Cc Me!

comment:26 Changed 11 years ago by zahanm@…

Cc: zahanm@… added

Cc Me!

comment:27 Changed 11 years ago by adambair@…

Cc Me!

comment:28 Changed 11 years ago by adambair@…

Cc: adambair@… added

Cc Me!

comment:29 Changed 11 years ago by florian.feldhaus@…

Cc: florian.feldhaus@… added

Cc Me!

comment:30 Changed 11 years ago by jknockaert@…

Cc: jknockaert@… added

Cc Me!

comment:31 Changed 11 years ago by ryandesign (Ryan Schmidt)

Has duplicate #24109.

comment:32 in reply to:  16 Changed 11 years ago by adambair@…

Replying to jamal@…:

I had installed pdftk on Leopard and then upgraded to Snow Leopard. It kept working. I only ran into trouble when I tried to reinstall all my ports. So, is there a way to get a precompiled version of pdftk?

I tried to install pdftk fresh on Snow Leopard and ran into the problems mentioned here. I searched for a solution or a precompiled pdftk for Snow Leopard but had no luck. I gave it another shot last week and actually found a pdftk installer for Snow Leopard that actually works!

Check it out: http://fredericiana.com/2010/03/01/pdftk-1-41-for-mac-os-x-10-6

comment:33 Changed 11 years ago by MartinBuchmann (Martin Buchmann)

Cc: Martin.Buchmann@… removed

Cc Me!

comment:34 Changed 11 years ago by andreas.wilm@…

Cc: andreas.wilm@… added

Cc Me!

comment:35 Changed 11 years ago by matteo.corti@…

Cc: matteo.corti@… added

Cc Me!

comment:36 Changed 11 years ago by sverek@…

Cc: sverek@… added

Cc Me!

comment:37 Changed 11 years ago by roland@…

Cc: roland@… added

Cc Me!

comment:38 Changed 11 years ago by 81joe81@…

Cc: 81joe81@… added

Cc Me!

comment:39 Changed 11 years ago by calsaiwing@…

Cc: calsaiwing@… added

Cc Me!

comment:40 Changed 11 years ago by ryandesign (Ryan Schmidt)

Has duplicate #25028.

comment:41 Changed 11 years ago by electronjunction-misc@…

Cc: electronjunction-misc@… added

Cc Me!

comment:42 Changed 11 years ago by lopusz@…

Cc: lopusz@… added

Cc Me!

comment:43 Changed 11 years ago by aitor.roncal@…

Cc: aitor.roncal@… added

Cc Me!

comment:44 Changed 11 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:45 Changed 11 years ago by macports@…

there is a precompiled version here for those who need it now! http://fredericiana.com/2010/03/01/pdftk-1-41-for-mac-os-x-10-6/

comment:46 Changed 11 years ago by takashi@…

Cc: takashi@… added

Cc Me!

comment:47 Changed 11 years ago by edwincheese@…

Cc: edwincheese@… added

Cc Me!

comment:48 Changed 11 years ago by enrique.fernandez.perdomo@…

Cc: enrique.fernandez.perdomo@… added

Cc Me!

comment:49 Changed 11 years ago by roland@…

Cc: roland@… added

Cc Me!

comment:50 Changed 11 years ago by henx@…

Cc: henx@… added

Cc Me!

comment:51 Changed 11 years ago by someuser12

Cc: macosx12345@… added

Cc Me!

comment:52 Changed 11 years ago by krissen

Cc: kristian.niemi@… added

Cc Me!

comment:53 Changed 10 years ago by chg5w@…

Cc: chg5w@… added

Cc Me!

comment:54 Changed 10 years ago by ryandesign (Ryan Schmidt)

Summary: gcc42 fails to build on Snow Leopard, precluding pdftkgcc42 fails to build on Snow Leopard

pdftk has been updated and now builds with gcc45, thus is no longer a consideration for this ticket.

comment:55 Changed 10 years ago by ivan@…

Also reproduced on MacPorts 1.9.1, OS X 10.6.4, while installing GNUStep.

comment:56 Changed 10 years ago by b.gagnon@…

Cc: b.gagnon@… added

Cc Me!

comment:57 Changed 10 years ago by jmroot (Joshua Root)

Keywords: snowleopard added
Resolution: wontfix
Status: newclosed

Erroring out early as of r74434. Closing given how long this has been open without a patch being produced. This shouldn't be a problem since gcc42 now has no dependents (when using default variants).

comment:58 Changed 9 years ago by kazuom@…

Cc: kazuom@… added

Cc Me!

comment:59 in reply to:  58 Changed 9 years ago by kazuom@…

Replying to kazuom@…:

Cc Me!

comment:60 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.