Opened 12 years ago

Closed 11 years ago

#23465 closed enhancement (duplicate)

Please add Accelerate variant

Reported by: tamyrvoll@… Owned by: har5ha
Priority: Low Milestone:
Component: ports Version:
Keywords: Cc: stechert@…, wa03 (Josh Lawrence)
Port: octave

Description

Recently the Octave (as well as py26-numpy) ports have started to depend on ATLAS. No reason have been given for this change. If the motivation is something other than actual bugs in Accelerate, a variant should be provided that let users avoid ATLAS (the build times for ATLAS are ridiculous, especially on older HW).

Attachments (1)

Portfile.diff (837 bytes) - added by tenomoto (Takeshi Enomoto) 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by tamyrvoll@…

Cc: tamyrvoll@… added

Cc Me!

comment:2 Changed 12 years ago by jmroot (Joshua Root)

Cc: stechert@… added; tamyrvoll@… removed
Keywords: atlas blas removed
Owner: changed from macports-tickets@… to alakazam@…
Version: 1.8.2

Please remember to cc the maintainers, and note that you do not need to be in cc when you are the reporter.

comment:3 Changed 12 years ago by alakazam@…

Owner: alakazam@… deleted

comment:4 Changed 12 years ago by wa03 (Josh Lawrence)

Cc: josh.k.lawrence@… added

Cc Me!

Changed 11 years ago by tenomoto (Takeshi Enomoto)

Attachment: Portfile.diff added

comment:5 Changed 11 years ago by tenomoto (Takeshi Enomoto)

This is a duplicate of #22997, which asks no_atlas for Tiger PPC. So I don't know which one should be closed. I also had a problem building atlas for ppc64 due to a problem with gcc43. atlas does not have g95 variant. Even if gcc43 and atlas can be built it takes very long time. The attached Portfile works for me to build octave for ppc64.

comment:6 Changed 11 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.