Opened 10 years ago

Closed 10 years ago

#26962 closed defect (invalid)

ipe@7.0.10 build error on leopard

Reported by: elswong@… Owned by: m.thon@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: ipe

Description

ipe fails to build on Leopard.

Here's partial output relevant to the build error.

:info:build g++  -dynamiclib  -o ../../../build/ipelets/image.so ../../../build/obj/ipelets/image.o -L../../../build/lib -lipe -framework Carbon -framework AppKit -framew
ork ApplicationServices -L/opt/local/lib -lQtGui -lpng -lQtCore -lz -lm  
:info:build ld warning: duplicate dylib /opt/local/lib/libz.1.dylib
:info:build Undefined symbols:
:info:build   "ipe::Page::append(ipe::TSelect, int, ipe::Object*)", referenced from:
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build   "ipe::Buffer::Buffer(char const*, int)", referenced from:
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build   "ipe::Bitmap::setColorKey(int)", referenced from:
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build   "ipe::Bitmap::~Bitmap()", referenced from:
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build   "ipe::Buffer::~Buffer()", referenced from:
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build   "ipe::Cascade::findLayout() const", referenced from:
:info:build       ImageIpelet::computeRect()       in image.o
:info:build   "ipe::Bitmap::Bitmap(int, int, ipe::Bitmap::TColorSpace, int, ipe::Buffer, ipe::Bitmap::TFilter, bool)", referenced from:
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build   "ipe::Buffer::Buffer(int)", referenced from:
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build   "ipe::Ipelet::~Ipelet()", referenced from:
:info:build       ImageIpelet::~ImageIpelet()in image.o
:info:build       ImageIpelet::~ImageIpelet()in image.o
:info:build   "ipe::Vector::ZERO", referenced from:
:info:build       __ZN3ipe6Vector4ZEROE$non_lazy_ptr in image.o
:info:build   "ipe::Bitmap::Bitmap(ipe::Bitmap const&)", referenced from:
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build   "ipe::Buffer::Buffer(ipe::Buffer const&)", referenced from:
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build   "ipe::Rect::Rect(ipe::Vector const&, ipe::Vector const&)", referenced from:
:info:build       ImageIpelet::computeRect()       in image.o
:info:build       ImageIpelet::computeRect()       in image.o
:info:build   "ipe::Image::Image(ipe::Rect const&, ipe::Bitmap)", referenced from:
:info:build       ImageIpelet::insertBitmap(QString)       in image.o
:info:build       ImageIpelet::insertJpeg(QString)       in image.o
:info:build ld: symbol(s) not found
:info:build collect2: ld returned 1 exit status
:info:build make[1]: *** [../../../build/ipelets/image.so] Error 1
:info:build make: *** [ipelets/image] Error 2
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_ipe/work/ipe-7.0.10/src" && /usr/b
in/make all IPEPREFIX=/opt/local MOC=/opt/local/bin/moc " returned error 2
:error:build Target org.macports.build returned: shell command failed
:debug:build Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for ipe): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for ipe is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_ipe/main.log

Change History (6)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to m.thon@…

comment:2 in reply to:  description Changed 10 years ago by m.thon@…

I cannot see from your build log what causes the problem. Could it be that you have another version of ipe installed somewhere on the system (e.g. in /usr/lib)?

comment:3 Changed 10 years ago by jmroot (Joshua Root)

It's not the complete build log. Please just attach the whole thing; that way we don't have to wonder whether your assessment of which parts are relevant was correct or not.

comment:4 in reply to:  description Changed 10 years ago by elswong@…

Sorry, this is my first time submitting a ticket. Next time I'll include the complete build log.

Also the problem has been resolved. It was in fact caused by having another installed version of ipe. Removing that fixes the problem. Thank you.

comment:5 Changed 10 years ago by m.thon@…

resolved

comment:6 Changed 10 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.