Opened 9 years ago

Closed 5 years ago

#29261 closed defect (fixed)

ggv @2.12.0_3 +universal build failure

Reported by: baf@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: ryandesign (Ryan Schmidt), cooljeanius (Eric Gallager)
Port: ggv

Description (last modified by jmroot (Joshua Root))

building ggv@2.12.0_3 as universal fails

from log:
:info:build ar cru .libs/libgtkgs.a .libs/Ggv-common.o .libs/Ggv-stubs.o .libs/Ggv-skels.o .libs/gtkgs.o .libs/ps.o .libs/ggvutils.o .libs/gsdefaults.o .libs/gsio.o .libs/ggv-msg-window.o .libs/ggv-prefs.o .libs/ggv-prefs-ui.o .libs/gtkchecklist.o .libs/cursors.o recent-files/librecent.a
:info:build /usr/bin/ranlib: archive member: .libs/libgtkgs.a(librecent.a) fat file for cputype (16777223) cpusubtype (3) is not an object file (bad magic number)

Attachments (1)

ggv.log (209.4 KB) - added by baf@… 9 years ago.
Full build log

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Description: modified (diff)

Attach the full log, please.

Changed 9 years ago by baf@…

Attachment: ggv.log added

Full build log

comment:2 in reply to:  description ; Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Replying to baf@…:

:info:build /usr/bin/ranlib: archive member: .libs/libgtkgs.a(librecent.a) fat file for cputype (16777223) cpusubtype (3) is not an object file (bad magic number)

This looks like your lipo command is not the correct one for your operating system. See comment:ticket:23343:14 and comment:ticket:24825:3.

comment:3 Changed 9 years ago by baf@…

No ar and ranlib seems ok. but removing recent/librecent.a from the link on the line above lets it compile to the end and seems to work.

so using:

/bin/sh ../libtool --mode=link /usr/bin/gcc-4.2  -O2 -arch x86_64 -arch i386 -L/opt/local/lib -arch x86_64 -arch i386 -o libgtkgs.la   Ggv-common.lo Ggv-stubs.lo Ggv-skels.lo gtkgs.lo ps.lo ggvutils.lo gsdefaults.lo gsio.lo ggv-msg-window.lo ggv-prefs.lo ggv-prefs-ui.lo gtkchecklist.lo cursors.lo -L/opt/local/lib -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 -lm -lfreetype -lfontconfig -lpng14 -lgconf-2 -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lintl   -lpopt  -L/opt/local/lib -lX11  -L/opt/local/lib -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 -lm -lfreetype -lfontconfig -lpng14 -lgconf-2 -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lintl   -lpopt  -L/opt/local/lib -lX11

instead of:

/bin/sh ../libtool --mode=link /usr/bin/gcc-4.2  -O2 -arch x86_64 -arch i386 -L/opt/local/lib -arch x86_64 -arch i386 -o libgtkgs.la   Ggv-common.lo Ggv-stubs.lo Ggv-skels.lo gtkgs.lo ps.lo ggvutils.lo gsdefaults.lo gsio.lo ggv-msg-window.lo ggv-prefs.lo ggv-prefs-ui.lo gtkchecklist.lo cursors.lo -L/opt/local/lib -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 -lm -lfreetype -lfontconfig -lpng14 -lgconf-2 -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lintl   -lpopt  -L/opt/local/lib -lX11  -L/opt/local/lib -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 -lm -lfreetype -lfontconfig -lpng14 -lgconf-2 -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lintl   -lpopt  -L/opt/local/lib -lX11 recent-files/librecent.a 

Lets it compile to the end and everything looks to work after that.

comment:4 Changed 9 years ago by baf@…

Oh lipo looks ok to. Works as expected on other files.

comment:5 in reply to:  2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign@…:

Replying to baf@…:

:info:build /usr/bin/ranlib: archive member: .libs/libgtkgs.a(librecent.a) fat file for cputype (16777223) cpusubtype (3) is not an object file (bad magic number)

This looks like your lipo command is not the correct one for your operating system. See comment:ticket:23343:14 and comment:ticket:24825:3.

I take it back, I get the same error on my system.

comment:6 Changed 8 years ago by jmroot (Joshua Root)

Apparently it's trying to put an archive inside another archive, and ranlib doesn't support that.

This software appears to be dead upstream since 2005, and even the long_description suggests it is obsolete. We should probably just remove it.

comment:7 Changed 6 years ago by smithsp (Sterling Smith)

I second the opinion that this port should be removed. I just installed it fine, but was getting errors when trying to run it:

>ggv

(process:88488): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(process:88488): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(process:88488): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(process:88488): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised

(ggv:88488): GGV-WARNING **: Could not get GGV control: 'Unknown CORBA exception id: 'IDL:omg.org/CORBA/COMM_FAILURE:1.0''

(ggv:88488): GGV-WARNING **: Failed to create a new window.

(ggv:88488): GGV-WARNING **: No windows could be opened. Exiting...

I'm not sure if this needs to be raised in a separate ticket...

comment:8 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:9 in reply to:  6 Changed 6 years ago by cooljeanius (Eric Gallager)

Replying to jmr@…:

Apparently it's trying to put an archive inside another archive, and ranlib doesn't support that.

I ran into this issue with another port that I was working on, and removing the --disable-dependency-tracking flag from configure.universal_args and then switching to the muniversal PortGroup allowed it to build correctly. I think the issue is more with putting a fat archive inside another archive, rather than just trying to put any old archive inside another archive.

comment:10 in reply to:  7 Changed 5 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Replying to smithsp@…:

I second the opinion that this port should be removed. I just installed it fine, but was getting errors when trying to run it:

>ggv

(process:88488): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(process:88488): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(process:88488): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(process:88488): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised

(ggv:88488): GGV-WARNING **: Could not get GGV control: 'Unknown CORBA exception id: 'IDL:omg.org/CORBA/COMM_FAILURE:1.0''

(ggv:88488): GGV-WARNING **: Failed to create a new window.

(ggv:88488): GGV-WARNING **: No windows could be opened. Exiting...

I'm not sure if this needs to be raised in a separate ticket...

Marked obsolete, replaced by evince in r121622.

Note: See TracTickets for help on using tickets.