Opened 9 years ago

Closed 9 years ago

#30392 closed defect (fixed)

splash: gcc44 should not be default variant if user chooses other gcc variant

Reported by: mf2k (Frank Schima) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.99
Keywords: Cc: danieljprice (Daniel Price)
Port: splash

Description

I'm running the latest macports from trunk. I see the following strange error with the splash port:

$ port info splash
Error: splash: Variant gcc45 conflicts with gcc44
Error: Unable to open port: Error evaluating variants

In the portfile I see the following:

default_variants    +gcc44 +pgplot

And in my variants.conf file I have the following:

+python26 +gcc45

So it appears that variants with conflicts should not appear in default_variants. I'm not sure where the problem is exactly, base or the port. But certainly port info does not need to evaluate variants before executing.

I'm Cc'ing the maintainer of the splash port.

Attachments (1)

Portfile (3.0 KB) - added by danieljprice (Daniel Price) 9 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by mf2k (Frank Schima)

@ daniel.price: The splash port needs to remove +gcc44 as a default_variant and instead use something like the following. Is it alright if I update the port?

if { ![variant_isset gcc42] && ![variant_isset gcc43] && ![variant_isset gcc44] && ![variant_isset gcc45] && ![variant_isset gcc46]} {
	default_variants      +gcc44
}

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Port: splash added
Summary: Variant conflict causes port info to failsplash: gcc44 should not be default variant if user chooses other gcc variant

comment:3 Changed 9 years ago by mf2k (Frank Schima)

@ryandesign: I still think that there is "base" issue involved here.

Changed 9 years ago by danieljprice (Daniel Price)

Attachment: Portfile added

comment:4 Changed 9 years ago by danieljprice (Daniel Price)

Cc: daniel.price@… removed

Cc Me!

comment:5 Changed 9 years ago by danieljprice (Daniel Price)

Cc: daniel.price@… added

Cc Me!

comment:6 Changed 9 years ago by danieljprice (Daniel Price)

Hi @macsforever2000,

Sorry about that!

I've made the changes in the Portfile. There were some other things to fix as @ryandesign mentioned (from http://lists.macosforge.org/pipermail/macports-dev/2011-June/014932.html) so I've done these at the same time.

Hopefully that should all work as expected now. In general though you should feel free to make changes.

(New Portfile attached)

Daniel

comment:7 Changed 9 years ago by danieljprice (Daniel Price)

btw, I've (re-)tested the Portfile on my own machine and seems to work OK

comment:8 in reply to:  3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Component: baseports

Replying to macsforever2000@…:

@ryandesign: I still think that there is "base" issue involved here.

Let's discuss that on the mailing list then, to come to an agreement about what the issue is and how it should be solved. This ticket is specifically about resolving this problem for the splash port.

comment:9 Changed 9 years ago by mf2k (Frank Schima)

splash updated in r82451.

comment:10 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.