Opened 7 years ago

Closed 7 years ago

#31931 closed defect (fixed)

dnsmasq @2.59 PID file not removed on unload

Reported by: m@… Owned by: nerdling (Jeremy L)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: dnsmasq

Description

The package dnsmasq provides the possibility to load and unload dnsmasq. When running port load dnsmasq, file /opt/local/var/run/dnsmasq.pid will be created.

However, when running port unload dnsmasq, that file will not be removed.

Change History (8)

comment:1 Changed 7 years ago by m@…

Cc: m@… added

Cc Me!

comment:2 Changed 7 years ago by nerdling (Jeremy L)

Cc: snc@… m@… removed
Owner: changed from macports-tickets@… to snc@…
Status: newassigned

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: openmaintainer@… removed
Status: assignednew

comment:4 Changed 7 years ago by nerdling (Jeremy L)

Status: newassigned

comment:5 Changed 7 years ago by nerdling (Jeremy L)

Permissions on the PID file prevent removal of the PID file. The default location needs to be inside a directory that the process can own.

comment:6 Changed 7 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: assignedclosed

I put the PID inside a fully-writable directory, r86875.

comment:7 Changed 7 years ago by m@…

Resolution: fixed
Status: closedreopened

There seems to be a regression as file /opt/local/var/run/dnsmasq.pid is created again (instead of var/run/dnsmasq/dnsmasq.pid).

comment:8 Changed 7 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: reopenedclosed

Thanks for catching that: fixed again in r94554.

Note: See TracTickets for help on using tickets.