Opened 9 years ago

Closed 9 years ago

#32392 closed defect (worksforme)

lmms 0.4.8 build failed on plugin - unsupported platform

Reported by: reid@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: lmms

Description (last modified by ryandesign (Ryan Schmidt))

Not exactly sure what's going on here (10.6.8 w/ xcode 3.2.6).

[  0%] Building CXX object src/CMakeFiles/fltk.dir/Fl.cxx.o
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk/src/Fl.cxx:600:3: error: #error unsupported platform
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk/src/Fl.cxx:687:3: error: #error unsupported platform
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk/src/Fl.cxx:1256:3: error: #error unsupported platform
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk/src/Fl.cxx:1291:3: error: #error unsupported platform
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk/src/Fl.cxx:1313:3: error: #error platform unsupported
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk/src/Fl.cxx:1474:3: error: #error unsupported platform
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk/src/Fl.cxx:1496:25: error: Fl_cocoa.mm: No such file or directory
gmake[5]: *** [src/CMakeFiles/fltk.dir/Fl.cxx.o] Error 1
gmake[5]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk'
gmake[4]: *** [src/CMakeFiles/fltk.dir/all] Error 2
gmake[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk'
gmake[3]: *** [all] Error 2
gmake[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8/plugins/zynaddsubfx/fltk'
make[2]: *** [plugins/zynaddsubfx/CMakeFiles/libfltk] Error 2
make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8'
make[1]: *** [plugins/zynaddsubfx/CMakeFiles/libfltk.dir/all] Error 2
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8'
make: *** [all] Error 2
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8'
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/work/lmms-0.4.8" && /usr/bin/make -w all " returned error 2
Error: Target org.macports.build returned: shell command failed (see log for details)
Warning: the following items did not execute (for lmms): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Log for lmms is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/lmms/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (3)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: reid@… removed
Description: modified (diff)
Keywords: lmms removed

Please use WikiFormatting so your posts are legible. There's no need to repeat the port name in the Keywords field nor to Cc yourself on tickets you reported.

This is probably a duplicate of, related to, or perhaps resolved by #24428 and/or #30630.

comment:2 Changed 9 years ago by jmroot (Joshua Root)

Does this still happen with 0.4.12?

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

No response from reporter; presumed fixed.

Note: See TracTickets for help on using tickets.