Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#32400 closed update (fixed)

update root to 5.32.00

Reported by: cjones051073 (Chris Jones) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: haspatch maintainer Cc: cdeil (Christoph Deil)
Port: root

Description

Attached Portfile and configure patch updates root to v5.32.00

Also address the issue with the fftw3 variant in Ticket #32383

Other changes are :-

  • Enables the gcc46 variant, as the new ROOT version now supports this compiler
  • disable the opengl variant by default. This variant requires flew to have been built with the +x11 variant enabled, which is not the default, and compilation fails. No major lose, as opengl support is not that important.
  • foce the use of llvm compiler on 10.7 + Xcode 4.2, as clang has a few problems.

Chris

Attachments (3)

root.diff (3.4 KB) - added by cjones051073 (Chris Jones) 10 years ago.
patch-configure.diff (1.4 KB) - added by cjones051073 (Chris Jones) 10 years ago.
root-V2.diff (5.8 KB) - added by cjones051073 (Chris Jones) 10 years ago.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by cjones051073 (Chris Jones)

Attachment: root.diff added

Changed 10 years ago by cjones051073 (Chris Jones)

Attachment: patch-configure.diff added

comment:1 Changed 10 years ago by cjones051073 (Chris Jones)

I just released the new ROOT version now supports python 3.2, so here is an update to the patch that adds a python32 variant as well.

Chris

Changed 10 years ago by cjones051073 (Chris Jones)

Attachment: root-V2.diff added

comment:2 Changed 10 years ago by cdeil (Christoph Deil)

Cc: Deil.Christoph@… added

Cc Me!

comment:3 Changed 10 years ago by cdeil (Christoph Deil)

Works for me (Lion, XCode 4.2, python 2.7). I also tried ROOT 5.32 with clang and didn't see any problems apart from minor compiler warnings.

comment:4 Changed 10 years ago by cjones051073 (Chris Jones)

Thanks for the confirmation.

Regarding clang, I had a compilation problem which appeared to disappear when I switched to llvm, but now if I try again I cannot reproduce that problem...

For the moment, I think I'm still happier sticking to llvm though, until I understand what is going on....

Chris

comment:5 Changed 10 years ago by cjones051073 (Chris Jones)

Any news on getting this released ? It has some fixes that would be nice to get out to users.

cheers Chris

comment:6 Changed 10 years ago by pixilla (Bradley Giesbrecht)

Keywords: haspatch maintainer added

jonesc: When creating a ticket with patches for ports you maintain adding the "haspatch" and "maintainer" keywords may help your ticket get quicker attention.
See "Keywords:" in the Trac Ticket Guidelines

comment:7 Changed 10 years ago by cjones051073 (Chris Jones)

Thanks for the advice, I missed these points in the guidelines.... ;)

cheers Chris

comment:8 Changed 10 years ago by pixilla (Bradley Giesbrecht)

Resolution: fixed
Status: newclosed

Changeset r87844

comment:9 in reply to:  7 Changed 10 years ago by pixilla (Bradley Giesbrecht)

Replying to jonesc@…:

Thanks for the advice, I missed these points in the guidelines.... ;)

Thanks for the patches..... ;)

Note: See TracTickets for help on using tickets.