Opened 10 years ago

Closed 3 years ago

#33522 closed defect (fixed)

tovid package does not currently work

Reported by: dave.branton@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: tovid sox Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: tovid

Description (last modified by ryandesign (Ryan Schmidt))

There are multiple problems with this package.

  1. It fails to install the dependancy md5sum. This isn't a showstopper, the dependancy can be installed manually.
  2. The scripts use the utility 'readlink', but pass it parameters that the osx version of readlink does not understand. Replacing readlink with greadlink (from the coreutils package) fixes the problem.
  3. The final problem, that I have not yet been able to overcome, is that it appears to install the incorrect version of sox. Sox bails out complaining about incorrect parameters.

Change History (6)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to macports@…
  1. As far as I am aware, no such software is available in MacPorts. md5sum is a utility commonly available on Linux, but not OS X. openssl provides similar capability; if tovid is not yet capable of using openssl instead of md5sum, tovid should be patched to gain that capability.
  2. Ideally tovid should be patched to work with OS X's BSD readline; if that's not possible, then patching it to use greadlink, and adding a dependency on coreutils, would be acceptable.
  3. There is only one version of sox (or any other port) available in MacPorts. If tovid is not compatible with the version of sox currently in MacPorts, tovid should be patched to be compatible with it.

comment:2 Changed 10 years ago by dave.branton@…

Sorry, I should have mentioned that I installed md5sha1sum to resolve the first problem.

Who looks after the tovid port in macports? Is this the right place to report the issue.

comment:3 Changed 9 years ago by jmroot (Joshua Root)

First part is a duplicate of #24151. Other parts may be fixed with a newer tovid version (see e.g. #26454).

comment:4 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports@… to macports-tickets@…

comment:5 Changed 3 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added

comment:6 Changed 3 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: newclosed

In 691c4d612999c1985d69b59722027fc216f26c8b/macports-ports (master):

tovid: update version 0.31->0.35.2

  • add license
  • update dependencies
  • switch to GitHub

Fixes #26454
Fixes #33522
Fixes #24151
See #53467

Note: See TracTickets for help on using tickets.