Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#33525 closed defect (duplicate)

Halting during: port -d selfupdate from base 2.0.3 to 2.0.4

Reported by: richard@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.0.4
Keywords: selfupdate, sqlite3 Cc:
Port:

Description (last modified by ryandesign (Ryan Schmidt))

When issuing a "sudo port -d selfupdate" on a base 2.0.3.

I recieve the following error:

Error: /opt/local/bin/port: port selfupdate failed: Error installing new MacPorts base: shell command failed (see log for details)

The cause appears to be:

"ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
make[2]: *** [registry.dylib] Error 1"

I have attached the full log of the command to this bug report.

Attachments (1)

selfupdatelog.txt (26.9 KB) - added by richard@… 10 years ago.
self update log

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by richard@…

Attachment: selfupdatelog.txt added

self update log

comment:1 Changed 10 years ago by neverpanic (Clemens Lang)

Resolution: duplicate
Status: newclosed

Duplicate of #33523, #25318, #30932. The culprit here is Mono.framework installing /usr/bin/pkg-config and thus messing with Apple-owned namespace on the filesystem. See #30932 for more info and the bug report on the Mono bugtracker aboout this.

Uninstall Mono.framework, move it aside during the update or move /usr/bin/pkg-config somewhere else.

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Note: See TracTickets for help on using tickets.