Opened 7 years ago

Closed 3 years ago

#34617 closed enhancement (duplicate)

make all ports independent of which version of Perl is installed or the major one

Reported by: BjarneDMat Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: pixilla (Bradley Giesbrecht), nonstop.server@…, cooljeanius (Eric Gallager)
Port:

Description

ports can be made independent of which version of Perl is installed or the major one by

1) setting a portgroup:
   PortGroup           perl5 1.0
2) change all hard-coded instances of perl5.12 and p5.12 to
   perl${perl5.major} and p${perl5.major}

But as pointed out in #34461 by Ryan, there are tons of ports that are hard-coded this way.

This mega-patch implements the above in all 104 affected ports

Incidentially, it thus also invalidates #34461 & #34357

This has been discussed on the dev-list starting with
http://lists.macosforge.org/pipermail/macports-dev/2012-May/019263.html

Attachments (3)

patch-perl5.xx.diff (104.1 KB) - added by BjarneDMat 7 years ago.
the result of svn diff after having applied perl5-16.bash to a completely fresh svn copy
perl5.bash (2.8 KB) - added by BjarneDMat 7 years ago.
my original scipt that works in a separate file structure
perl5-16.bash (2.0 KB) - added by BjarneDMat 7 years ago.
my script that works directly on the port files

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by BjarneDMat

Attachment: patch-perl5.xx.diff added

the result of svn diff after having applied perl5-16.bash to a completely fresh svn copy

comment:1 Changed 7 years ago by BjarneDMat

!!!NOTE!!! if you run either script, you'll have to revert

lang/perl5
lang/perl5.12

Changed 7 years ago by BjarneDMat

Attachment: perl5.bash added

my original scipt that works in a separate file structure

Changed 7 years ago by BjarneDMat

Attachment: perl5-16.bash added

my script that works directly on the port files

comment:2 Changed 7 years ago by nonstop.server@…

Cc: nonstop.server@… added

Cc Me!

comment:3 Changed 7 years ago by jmroot (Joshua Root)

Same problem as mentioned in #34461.

comment:4 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:5 Changed 3 years ago by mf2k (Frank Schima)

Resolution: wontfix
Status: newclosed

This has been discussed over the years on the developers list. We are not going in this direction with perl.

comment:6 Changed 3 years ago by mf2k (Frank Schima)

Resolution: wontfix
Status: closedreopened

comment:7 Changed 3 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: reopenedclosed
Version: 2.1.1

Calling this a duplicate of #48365 instead. The patch here is no longer useful.

Note: See TracTickets for help on using tickets.