Opened 6 years ago

Closed 5 years ago

#41352 closed defect (fixed)

ta-lib @ 0.4.0 build failure

Reported by: jb.morgado@… Owned by: cedstrom@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: ta-lib

Description (last modified by anddam (Andrea D'Amore))

ta-lib 0.4.0 fails to build with the message: Error: org.macports.configure for port ta-lib returned: configure failure: command execution failed

The actual error is:

make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_finance_ta-lib/ta-lib/work/ta-lib/src/tools/gen_code'
/usr/bin/clang -DHAVE_CONFIG_H -I. -I../../../include  -I../../ta_common -I/opt/local/include  -pipe -Os -arch x86_64 -MT gen_code-gen_code.o -MD -MP -MF .deps/gen_code-gen_code.Tpo -c -o gen_code-gen_code.o `test -f 'gen_code.c' || echo './'`gen_code.c
gen_code.c:3456:18: warning: format string is not a string literal (potentially insecure) [-Wformat-security]
   fprintf( out, prefix );
                 ^~~~~~
gen_code.c:3456:18: warning: format string is not a string literal (potentially insecure) [-Wformat-security]
   fprintf( out, prefix );
                 ^~~~~~
1 warning generated.
1 warning generated.
mv -f .deps/gen_code-gen_code.Tpo .deps/gen_code-gen_code.Po
mv -f .deps/gen_code-gen_code.Tpo .deps/gen_code-gen_code.Po
mv: rename .deps/gen_code-gen_code.Tpo to .deps/gen_code-gen_code.Po: No such file or directory
make[3]: *** [gen_code-gen_code.o] Error 1

Full log attached.

Attachments (1)

ta-lib-error.zip (18.0 KB) - added by jb.morgado@… 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by jb.morgado@…

Attachment: ta-lib-error.zip added

comment:1 Changed 6 years ago by ci42

Owner: changed from macports-tickets@… to cedstrom@…
Port: ta-lib added
Summary: [ta-lib] [0.4.0] [falis to build with message: configure failure: command execution failed]ta-lib @ 0.4.0 build failure

In the future please don't forget to Cc the maintainer and fill in the port field.

comment:2 Changed 5 years ago by anddam (Andrea D'Amore)

Description: modified (diff)

comment:3 Changed 5 years ago by anddam (Andrea D'Amore)

The actual error is the double mv command, that's probably due to some issue in makefiles badly handling parallel jobs.

I can reproduce the issue on 10.9 using Xcode 5.0.2 and I can build the port correctly specifying build.jobs=1.

We can either force single job building or go fix the actual issue that should be reported upstream as well.

comment:4 Changed 5 years ago by anddam (Andrea D'Amore)

Resolution: fixed
Status: newclosed

Changed to single job building in r115788.

Note: See TracTickets for help on using tickets.