Opened 6 years ago

Closed 5 years ago

#42752 closed defect (duplicate)

libgcc +universal on OSX 10.6.8 build error

Reported by: maximilian.behr@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: cooljeanius (Eric Gallager)
Port: libgcc

Description

I try to install gcc46 +universal. The error log ist attached

Attachments (2)

main.log (333.5 KB) - added by maximilian.behr@… 6 years ago.
main.2.log (16.2 MB) - added by maximilian.behr@… 6 years ago.

Change History (6)

Changed 6 years ago by maximilian.behr@…

Attachment: main.log added

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Keywords: gcc46 +universal removed
Owner: changed from macports-tickets@… to mww@…
Port: libgcc added; gcc46 removed
Summary: port install gcc46 +universal on OSX 10.6.8 failedlibgcc +universal on OSX 10.6.8 build error

In the future, please fill in the Port field with the port that actually failed and Cc the port maintainers (port info --maintainers libgcc).

Since this was not a clean build log, clean libgcc and try again. Attach the new main.log if it fails again.

Changed 6 years ago by maximilian.behr@…

Attachment: main.2.log added

comment:2 Changed 6 years ago by cooljeanius (Eric Gallager)

This is the actual error from the log:

:info:build no
:info:build configure: error: GNU Fortran is not working; please report a bug in http://gcc.gnu.org/bugzilla, attaching /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc48/libgcc/work/build/x86_64-apple-darwin10/libgfortran/config.log
:info:build config.status: executing gstdint.h commands
:info:build make[1]: *** [configure-target-libgfortran] Error 1
:info:build make[1]: *** Waiting for unfinished jobs....
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc48/libgcc/work/build'
:info:build make: *** [bootstrap] Error 2

In which case that means that this is a duplicate of #40548 (just like #41753 was), which means that is actually an issue with mpfr (#42732) and/or libmpc (#42733) that would have been caught if their testsuites had been run automatically (#42731)

comment:3 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #40548.

Note: See TracTickets for help on using tickets.