Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#42920 closed defect (duplicate)

py34-matplotlib @1.3.1_4: specific variants broken due to missing python subports

Reported by: petrrr Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: neverpanic (Clemens Lang), mojca (Mojca Miklavec)
Port: py-matplotlib py-cairo py-gobject3

Description (last modified by mf2k (Frank Schima))

Some of the provided variants are currently broken for the py34 sub-port, because the respective Python dependencies to not provide the sub-port yet:

  • variant +cairo lacks port:py34-cairo dependency;
  • variant +gtk3 lacks port:py34-gobject3;

Change History (5)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Cc: cal@… added; sean@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to sean@…
Port: py-cairo py-gobject3 added

comment:2 Changed 6 years ago by petrrr

r118226: implements the missing dependencies, but there seem to be build problems. Will provide details as soon as the various build tests have finished.

comment:3 Changed 6 years ago by petrrr

Okay, the build now fails only for the +gtk3 variant, but the problem was already reported in #42918. Therefore this ticket can be closed!

comment:4 Changed 6 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:5 Changed 6 years ago by mojca (Mojca Miklavec)

Resolution: duplicate
Status: newclosed

Not sure if closing the ticket counts as fixed or duplicate. I cannot pick half-closed (cairo - #42922) half-duplicate (gtk3 - #42918) ;)

Last edited 6 years ago by mojca (Mojca Miklavec) (previous) (diff)
Note: See TracTickets for help on using tickets.