Opened 10 years ago

Closed 9 years ago

#26952 closed defect (wontfix)

gimp-app: ScriptExec_Prefix.pch: No such file or directory

Reported by: hanche Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: dbevans (David B. Evans), astrofitz (Michael Fitzgerald), dfokkema@…, raimue (Rainer Müller), code@…
Port: gimp-app

Description

This looks similar to ticket #26747 but is not identical.

The following build commands failed:
ScriptExec:
        CompileC build/ScriptExec.build/Deployment/ScriptExec.build/Objects-normal/x86_64/main.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c normal x86_64 c com.apple.compilers.gcc.4_2
(1 failure)

Note that “port clean --all gimp-app” did not help.

I am on Mac OS X 10.6.4, Xcode 3.2.4.

Attachments (2)

gimp-app-build.log (17.3 KB) - added by hanche 10 years ago.
Build log with -d flag
gimp-app-build-xcode-3.2.3.log (15.9 KB) - added by dbevans (David B. Evans) 10 years ago.
Debug log of successful build with Xcode 3.2.3 (really)

Download all attachments as: .zip

Change History (18)

Changed 10 years ago by hanche

Attachment: gimp-app-build.log added

Build log with -d flag

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Summary: gimp-app fails to buildgimp-app: ScriptExec_Prefix.pch: No such file or directory

The relevant error from the log seems to be:

cc1: error: /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-/com.apple.Xcode.0/SharedPrecompiledHeaders/ScriptExec_Prefix-fjqslffpxdgvupftqlldkqzqbvow/ScriptExec_Prefix.pch: No such file or directory

comment:2 Changed 10 years ago by dbevans (David B. Evans)

Interesting. Builds fine for me on 10.6.4 but with Xcode 3.2.3. Similar lines from log are

CompileC build/ScriptExec.build/Deployment/ScriptExec.build/Objects-normal/x86_64/main.o main.c normal x86_64 c com.apple.compilers.gcc.4_2
    cd /opt/local/var/macports/build/_Volumes_wdc-320_opt_macports_trunk_dports_aqua_gimp-app/work/ScriptExec
    setenv LANG en_US.US-ASCII
    /Developer/usr/bin/gcc-4.2 -x c -arch x86_64 -fmessage-length=0 -pipe -Wno-trigraphs -fpascal-strings -fasm-blocks -Os -mdynamic-no-pic -fvisibility=hidden -mmacosx-version-min=10.6 -I/opt/local/var/macports/build/_Volumes_wdc-320_opt_macports_trunk_dports_aqua_gimp-app/work/ScriptExec/build/ScriptExec.build/Deployment/ScriptExec.build/ScriptExec.hmap -Wmost -Wno-four-char-constants -Wno-unknown-pragmas -F/opt/local/var/macports/build/_Volumes_wdc-320_opt_macports_trunk_dports_aqua_gimp-app/work/ScriptExec/build/Deployment -I/opt/local/var/macports/build/_Volumes_wdc-320_opt_macports_trunk_dports_aqua_gimp-app/work/ScriptExec/build/Deployment/include -I/opt/local/var/macports/build/_Volumes_wdc-320_opt_macports_trunk_dports_aqua_gimp-app/work/ScriptExec/build/ScriptExec.build/Deployment/ScriptExec.build/DerivedSources/x86_64 -I/opt/local/var/macports/build/_Volumes_wdc-320_opt_macports_trunk_dports_aqua_gimp-app/work/ScriptExec/build/ScriptExec.build/Deployment/ScriptExec.build/DerivedSources -include /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-/com.apple.Xcode.0/SharedPrecompiledHeaders/ScriptExec_Prefix-fzazehzfqmokcnbldhnafjcbmkbb/ScriptExec_Prefix.pch -c /opt/local/var/macports/build/_Volumes_wdc-320_opt_macports_trunk_dports_aqua_gimp-app/work/ScriptExec/main.c -o /opt/local/var/macports/build/_Volumes_wdc-320_opt_macports_trunk_dports_aqua_gimp-app/work/ScriptExec/build/ScriptExec.build/Deployment/ScriptExec.build/Objects-normal/x86_64/main.o

Full log attached. An issue with Xcode 3.2.4?

Changed 10 years ago by dbevans (David B. Evans)

Debug log of successful build with Xcode 3.2.3 (really)

comment:3 Changed 10 years ago by dbevans (David B. Evans)

Cc: devans@… added

Cc Me!

comment:4 Changed 10 years ago by jmroot (Joshua Root)

I don't think it's warranted to leap to the conclusion that the corrupt PCH cache was caused by a regression in Xcode 3.2.4.

comment:5 Changed 10 years ago by dbevans (David B. Evans)

I meant to say that the possibility should be ruled out which it has.

After hesitantly upgrading to Xcode 3.2.4, the port continues to build properly for me.

I note that the port issues a command in pre-build to cleanup old precompiled headers.

Are there others who are experiencing this problem or is it specific to the reporter?

comment:6 Changed 10 years ago by astrofitz (Michael Fitzgerald)

I am seeing the same problem (ScriptExec_Prefix.pch).

comment:7 Changed 10 years ago by astrofitz (Michael Fitzgerald)

Cc: astrofitz@… added

Cc Me!

comment:8 Changed 10 years ago by dfokkema@…

I'm seeing the same build error... Xcode 3.2.4.

comment:9 Changed 10 years ago by dfokkema@…

Cc: dfokkema@… added

Cc Me!

comment:10 Changed 10 years ago by raimue (Rainer Müller)

Cc: raimue@… added

I wrote about the Xcode pre-compiled header cache on macports-dev last month. A possible solution is outlined there.

comment:11 Changed 10 years ago by code@…

Cc: code@… added

Cc Me!

comment:12 Changed 10 years ago by astrofitz (Michael Fitzgerald)

I was able to build this successfully today after previously encountering this error. I recently upgraded to Xcode 3.2.5.

comment:13 Changed 10 years ago by jmroot (Joshua Root)

To quote myself from #26887:

I wonder if Xcode.app running as a regular user is unable to delete cache files created by xcodebuild running as root. That is, maybe you need to delete /var/folders/*/*/-Caches-/com.apple.Xcode.* manually.

comment:14 in reply to:  13 ; Changed 10 years ago by david.hislop.1@…

Replying to jmr@…:

To quote myself from #26887:

I wonder if Xcode.app running as a regular user is unable to delete cache files created by xcodebuild running as root. That is, maybe you need to delete /var/folders/*/*/-Caches-/com.apple.Xcode.* manually.

That doesn't appear to to fit with my problem, reported in #27839 and marked as a duplicate of this ticket. The files in that dir are 644 and owned by me:

MacBook:~ david$ ls -l /var/folders/*/*/-Caches-/com.apple.Xcode.*total 6656
-rw-r--r--  1 david  staff  3077167 24 Dec 14:17 CachedSpecifications-Xcode
-rw-r--r--  1 david  staff   326165 26 Jun  2010 CachedSpecifications-xcodebuild

I tried setting CACHE_ROOT as mentioned in Xcode pre-compiled header cache. Also tried moving the CachedSpecifications* files to a temp dir and rebuilding. No change to behaviour in either case.

comment:15 in reply to:  14 Changed 10 years ago by david.hislop.1@…

Replying to david.hislop.1@…:

It now works. Yes, you do have to delete /var/folders/*/*/-Caches-/com.apple.Xcode.* manually, but you have to pick the right directory! :-(

ls -l as I did it above didn't find the right directory because /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches- is 700 owned by root:

MacBook:~ david$ ls -ld /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-
drwx------  10 root  wheel  340 12 Jan 12:00 /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-

Using sudo:

MacBook:~ david$ sudo ls -la /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-/com.apple.Xcode.0/SharedPrecompiledHeaders/ScriptExec_Prefix-fjqslffpxdgvupftqlldkqzqbvow
total 56120
drwxr-xr-x  4 root  wheel       136  3 Sep 10:46 .
drwx------  3 root  wheel       102  3 Sep 10:46 ..
-rw-r--r--  1 root  wheel  28726992  3 Sep 10:46 ScriptExec_Prefix.pch.gch
-rw-r--r--  1 root  wheel       625  3 Sep 10:46 ScriptExec_Prefix.pch.gch.hash-criteria

I sudo mv'd those two files to a temp directory and then sudo port -d upgrade gimp-app worked, rebuilding the above files:

MacBook:~ david$ sudo ls -la /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-/com.apple.Xcode.0/SharedPrecompiledHeaders/ScriptExec_Prefix-fjqslffpxdgvupftqlldkqzqbvow
total 56160
drwxr-xr-x  4 root  wheel       136 12 Jan 13:31 .
drwx------  3 root  wheel       102  3 Sep 10:46 ..
-rw-r--r--  1 root  wheel  28747472 12 Jan 13:31 ScriptExec_Prefix.pch.gch
-rw-r--r--  1 root  wheel       625 12 Jan 13:31 ScriptExec_Prefix.pch.gch.hash-criteria

I guess that the previous build was with Xcode 3.2.4. This one was with Xcode 3.2.5. Possibly there is an incompatibility with the pre-compiled header format between the two versions. In any case, rebuilding fixed it.

I left -d on to check something I noticed in a previous build that might be OK but looked a little odd to me. In the successful build it was the same as the previous builds that failed: the "clean" stage uses a path different from the "build" stage.

=== CLEAN NATIVE TARGET ScriptExec OF PROJECT ScriptExec WITH THE DEFAULT CONFIGURATION (Default) ===Check dependenciesClean.Remove clean build/Default/ScriptExec.app
    /bin/rm -rf /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/build/Default/Scr
iptExec.app

Clean.Remove clean /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-/com.apple.Xcode.0/SharedPrecompiledHeaders/ScriptExec_Prefix-eambjzimyyjxqdbnehsrhulsrtsw/ScriptExec_Prefix.pch.gch
    /bin/rm -rf /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-/com.apple.Xcode.0/SharedPrecompiledHeaders/ScriptExec_Prefix-eambjzimyyjxqdbnehsrhulsrtsw/ScriptExec_Prefix.pch.gch

The above uses ScriptExec_Prefix-eambjzimyyjxqdbnehsrhulsrtsw.

=== BUILD NATIVE TARGET ScriptExec OF PROJECT ScriptExec WITH CONFIGURATION Deployment ===
Check dependencies
ProcessPCH /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-/com.apple.Xcode.0/SharedPrecompiledHeaders/ScriptExec_Prefix-fjqslffpxdgvupftqlldkqzqbvow/ScriptExec_Prefix.pch.gch ScriptExec_Prefix.pch normal x86_64 c com.apple.compilers.gcc.4_2

The above uses ScriptExec_Prefix-fjqslffpxdgvupftqlldkqzqbvow.

Is that intentional?

comment:16 Changed 9 years ago by jmroot (Joshua Root)

Resolution: wontfix
Status: newclosed

It looks like this is a result of Xcode messing up its PCH cache somehow, so there doesn't appear to be anything that could be done about it in the port.

Note: See TracTickets for help on using tickets.