Opened 9 years ago

Closed 9 years ago

#33165 closed defect (fixed)

transfig: error: empty character constant

Reported by: jhklubek@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone: MacPorts 2.0.4
Component: base Version: 2.0.3
Keywords: xmkmf Cc: lesn0011@…, anddam (Andrea D'Amore), ryandesign (Ryan Schmidt)
Port:

Description (last modified by ryandesign (Ryan Schmidt))

I have a brand new Mac that is fully patched with OS X 10.7.3 and Xcode 4.2.1 from the App store. I have tried sudo port install transfig with MacPorts 2.0.3 and receive an shell command failed error during configuration of this port.

I have run sudo port -d transfig and have attached a text file with the details of the error.

I need this package in order to install xfig so any help is appreciated.

Attachments (3)

error.txt (45.5 KB) - added by jhklubek@… 9 years ago.
Debug for transfig
main.log (76.3 KB) - added by jhklubek@… 9 years ago.
Main log file
main2.log (57.3 KB) - added by jhklubek@… 9 years ago.

Download all attachments as: .zip

Change History (23)

Changed 9 years ago by jhklubek@…

Attachment: error.txt added

Debug for transfig

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Milestone: MacPorts 2.0.4
Summary: Issues installing transfig in Liontransfig: error: empty character constant

The first error in the log is:

/opt/local/lib/X11/config/Imake.rules:1674:27: error: empty character constant

However, since this was not a clean attempt, please "sudo port clean" transfig and try again, then attach the main.log file if it fails again.

comment:2 Changed 9 years ago by jhklubek@…

I ran the following:

sudo port clean transfig
sudo port clean xfig (since I tried this first)
sudo port -fp uninstall --follow-dependents installed (to clean up anything installed before)
sudo port install transfig

I still receive an error and am attaching a copy of main.log

Changed 9 years ago by jhklubek@…

Attachment: main.log added

Main log file

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: lesn0011@… added

Has duplicate #33185.

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

Possibly an incompatibility with clang. Try using a different compiler.

comment:5 Changed 9 years ago by jhklubek@…

Have now attempted with other compilers without success. Attaching main2.log for information

Changed 9 years ago by jhklubek@…

Attachment: main2.log added

comment:6 in reply to:  5 Changed 9 years ago by chiefgecko@…

Replying to jhklubek@…:

Have now attempted with other compilers without success. Attaching main2.log for information

This seems to workaround the problem (re: Changeset 84946) for 10.7.3 + 4.2.1. This bug is most likely a duplicate of #84946

sudo port uninstall imake
sudo port install imake configure.compiler=llvm-gcc-4.2

#package I was installing with exact match behavior as described in #33165
sudo port install tightvnc

comment:7 Changed 9 years ago by jhklubek@…

Running the imake commands and then running the sudo port install transfig fixed the problem

comment:8 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

*DON'T* set configure.compiler=llvm-gcc-4.2 for imake. You are just *MASKING* the problem and making it worse to fix down the road.

comment:9 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Component: portsbase
Keywords: xmkmf added
Port: transfig removed
Resolution: duplicate
Status: newclosed

Update base to latest trunk. This was a bug in use_xmkmf that is fixed by: r89537 r89538 r89539

See #31504

comment:10 in reply to:  9 ; Changed 9 years ago by anddam (Andrea D'Amore)

Resolution: duplicate
Status: closedreopened

This ticket has been marked as duplicate of #33185 and #33185 has been marked as duplicate of this one.

One of them should stay as non-duplicated or be in turn a duplicate of #31504 in order to create a chain and let people figure the status of the issue for xfig.

Replying to chiefgecko@…:

This seems to workaround the problem (re: Changeset 84946) for 10.7.3 + 4.2.1. This bug is most likely a duplicate of #84946

The sharp sign '#' marks tickets, not changeset, you can use 'r' for revisions r84946 and a direct URI to a changeset, they start with 'http://trac.macports.org/changeset/', e.g. c84946. cf. wiki formatting

Replying to jeremyhu@…:

Update base to latest trunk. This was a bug in use_xmkmf that is fixed by: r89537 r89538 r89539

I'm past those and still I see the issue with port xorg-cf-files and Xcode 4.2. Did I get wrong or was your comment suggesting the updated base should have fixed the issue?

comment:11 Changed 9 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added

Cc Me!

comment:12 in reply to:  10 Changed 9 years ago by anddam (Andrea D'Amore)

Replying to and.damore@…:

you can use 'r' for revisions r84946 and a direct URI to a changeset, they start with 'http://trac.macports.org/changeset/', e.g. c84946. cf. wiki formatting

I stand corrected, 'r' syntax is for changesets.

comment:13 in reply to:  9 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Owner: changed from macports-tickets@… to jeremyhu@…
Status: reopenednew

Replying to jeremyhu@…:

Update base to latest trunk. This was a bug in use_xmkmf that is fixed by: r89537 r89538 r89539

See #31504

Which ticket shall be the one tracking this MacPorts base issue -- #31504 or this one? I'd like to describe this fix in the ChangeLog and merge it to the 2.0 branch. We've had another duplicate filed, #33600.

comment:14 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

The issue was fixed in the version of base that shipped to address XCode 4.3 issues, so the base issue is fixed.

comment:15 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

You can do this in the affected ports to work around the issue until #31504 is fixed:

# http://trac.macports.org/ticket/31504
if {${configure.compiler} == "clang"} {  
    configure.compiler llvm-gcc-4.2  
} 
xmkmf.env-append IMAKECPP="${configure.cpp}" 

comment:16 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Actually, you should just need:

# http://trac.macports.org/ticket/31504
if {${configure.compiler} == "clang"} {  
    configure.compiler llvm-gcc-4.2  
}

The xmkmf.env-append is no longer needed with released base.

comment:17 in reply to:  16 Changed 9 years ago by ryandesign (Ryan Schmidt)

Replying to jeremyhu@…:

The issue was fixed in the version of base that shipped to address XCode 4.3 issues, so the base issue is fixed.

Oh! It was not mentioned in the ChangeLog. I've updated the ChangeLog with this information in r90712 and merged it back to the 2.0 branch in r90713.

Replying to jeremyhu@…:

Actually, you should just need:

Thanks, I've made that change in r90711.

comment:18 Changed 9 years ago by ryandesign (Ryan Schmidt)

Milestone: MacPorts 2.0.4

Since this issue has been fixed in base, can this ticket be closed?

comment:19 in reply to:  18 Changed 9 years ago by anddam (Andrea D'Amore)

Replying to ryandesign@…:

Since this issue has been fixed in base, can this ticket be closed?

I confirm transfig builds fine on 10.7.3 and Xcode 4.2.1, I suggest to close the ticket.

comment:20 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.