Opened 4 years ago

Closed 4 years ago

#47388 closed defect (fixed)

muniversal-1.0: configure options are restored incorrectly between architectures

Reported by: jasoncharney@… Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: pop2.mp@…
Port:

Description (last modified by larryv (Lawrence Velázquez))

Hello,
I'm new to MacPorts so sorry if I don't understand everything. I am trying to install OLA (+universal) and it fails when reaching the "gmp" stage (failure to configure gmp, also failure to upgrade libmicrohttpd after this). I tried cleaning the port but it still gives me the error. What is wrong? Thank you!

Attachments (2)

main.log (46.3 KB) - added by jasoncharney@… 4 years ago.
config.log (41.0 KB) - added by jasoncharney@… 4 years ago.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by jasoncharney@…

Attachment: main.log added

Changed 4 years ago by jasoncharney@…

Attachment: config.log added

comment:1 Changed 4 years ago by jasoncharney@…

Cc: jasoncharney@… added

Cc Me!

comment:2 Changed 4 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added; jasoncharney@… removed
Keywords: OLA removed
Owner: changed from macports-tickets@… to mcalhoun@…
Summary: gmp/OLA - failed to configure gmpgmp +universal: configuring i386 fails

You’re trying to build a universal GMP on an Intel 64 machine. The way MacPorts does this is by doing separate x86_64 and i386 builds and combining them at the end.

The value of CXX in the x86_64 configure environment is correct:

CXX='/usr/bin/clang++ -stdlib=libc++'

but the value in the i386 environment is wrong:

CXX='{/usr/bin/clang++ -stdlib=libc++}'

(Those braces indicate that the value is incorrectly being treated as a Tcl list.)

I couldn’t reproduce this initially, but I just pulled the latest ports tree and I see it now.

comment:3 Changed 4 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… removed
Description: modified (diff)
Owner: changed from mcalhoun@… to larryv@…
Port: gmp removed
Summary: gmp +universal: configuring i386 failsmuniversal-1.0: configure options are restored incorrectly between architectures

Looks like it was r134832. Shouldn’t be hard to fix.

comment:4 Changed 4 years ago by larryv (Lawrence Velázquez)

Resolution: fixed
Status: newclosed

r134863 should take care of it. Wait about half an hour for it to propagate, clean gmp, and try the install again.

comment:5 in reply to:  4 Changed 4 years ago by larryv (Lawrence Velázquez)

Sorry, I left out a step.

  1. Wait about half an hour for the change to propagate to our rsync ports distributions.
  2. Run sudo port clean gmp.
  3. Run sudo port selfupdate to actually pull down my fix.
  4. Try installing OLA again.

comment:6 Changed 4 years ago by jasoncharney@…

Excellent, that fixed the issue and I was able to correctly install ola +universal variant. Thank you for your very quick fix!!

comment:7 Changed 4 years ago by larryv (Lawrence Velázquez)

Cc: pop2.mp@… added
Resolution: fixed
Status: closedreopened

Has duplicate #47420.

comment:8 Changed 4 years ago by larryv (Lawrence Velázquez)

Resolution: fixed
Status: reopenedclosed

Josh worked around #47420 in r135061, and Jeremy did the same with db46 in r135175. I’ve hopefully fixed the underlying issue with muniversal-1.0 in r135550.

Note: See TracTickets for help on using tickets.