Opened 4 years ago

Last modified 14 months ago

#56803 assigned defect

pdf2htmlex doesn't build

Reported by: amadeus24 Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: Cc: paxperscientiam (Chris), Dave-Allured (Dave Allured)
Port: pdf2htmlex


After updating to 2.5.3, pdf2htmlex build end up with an error.

Attachments (2)

main.log (124.0 KB) - added by amadeus24 4 years ago.
bad.log (233.6 KB) - added by mdturnerinoz (Martin D Turner) 4 years ago.

Download all attachments as: .zip

Change History (15)

Changed 4 years ago by amadeus24

Attachment: main.log added


comment:1 Changed 4 years ago by mf2k (Frank Schima)

Cc: mojca removed
Keywords: pdf2htmlex doesn't build removed
Owner: set to mojca
Status: newassigned

comment:2 Changed 4 years ago by mojca (Mojca Miklavec)

I tried to update the port, but it seems that it's so heavily depending on internals of poppler (in fact having a private copy of poppler's sources integrated for one part, but depending on external poppler for the other) that it doesn't seem trivial to fix this without devoting quite some effort. Upstream development is declared stale, looking for a new developer, while poppler is very well known to break even APIs with each release, let alone keeping copies of its files working.

comment:3 Changed 4 years ago by mf2k (Frank Schima)

It has no obvious dependents. I say delete it.

$ port echo depends:pdf2htmlex

comment:4 Changed 4 years ago by mojca (Mojca Miklavec)

It's not about dependencies. It's a nifty little piece of software on its own. However, if it doesn't compile and if it isn't maintained, it's not really helpful.

comment:5 Changed 4 years ago by kencu (Ken)

let me try it against poppler-qt4-mac.

comment:6 Changed 4 years ago by kencu (Ken)

No go. The version of poppler in poppler-qt4-mac (0.61.1) is apparently too new to build it also.

comment:7 Changed 4 years ago by kencu (Ken)

If you want to make it build, we'd have to inspect <>.

It apparently builds on every system with that formula, including building on Mojave (for which they already have a prebuilt binary on their buildbot farm, apparently).

comment:8 Changed 4 years ago by mojca (Mojca Miklavec)

HB seems to fetch poppler 0.57.0 as part of pdf2htmlex build process.

Changed 4 years ago by mdturnerinoz (Martin D Turner)

Attachment: bad.log added

comment:9 Changed 4 years ago by mdturnerinoz (Martin D Turner)

I too am failing to build pdf2htmlex on Mojave (I am 10.14.2 on a Mac Pro). After doing all the usual clean activities and viewing previous problems with pdf2htmlex I decided to completely uninstall Mac Ports and reinstall it. Other ports build just fine bug pdf2htmlex still fails (see bad.log attached). I can provide whatever is necessary to help solve this problem as I am dependent on pdf2htmlex for some shell scripts I often use (which I cannot now use). I have Xcode 10.1 installed and build with. It's been quite a while since I reported a bug, so I hope I got all that is needed to proceed. let me know if not.

comment:10 Changed 3 years ago by paxperscientiam (Chris)

Cc: paxperscientiam added

comment:11 Changed 3 years ago by nachogt (Nacho García)

As of today, this problem persists in Catalina. The log file seems to indicate that "goo/gooList.h" is nowhere to be found. This is indeed a poppler source file, but I haven't been able to find a package that contains it.

Any news on how to build pdf2htmlex? I've been suggested to install it through Homebrew, but mixing Homebrew with MacPorts doesn't seem to be a great idea to me...

comment:12 Changed 19 months ago by bunk3m (Bunk3m)

Tried to install this port today. Apparently it got a bit further than what some have mentioned. It is failing:

:info:configure -- Checking for module 'libfontforge>=2.0.0'
:info:configure --   No package 'libfontforge' found
:info:configure Trying to locate old versions of fontforge...
:info:configure CMake Error at CMakeLists.txt:97 (message):
:info:configure   Error: cannot locate fontforge.h
:info:configure -- Configuring incomplete, errors occurred!
:info:configure See also "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_pdf2htmlex/pdf2htmlex/work/build/CMakeFiles/CMakeOutput.log".
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_pdf2htmlex/pdf2htmlex/work/build" && /opt/local/bin/cmake -DCMAKE_INSTALL_PREFIX='/opt/local' -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_C_COMPILER="$CC" -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_CXX_COMPILER="$CXX" -DCMAKE_FIND_FRAMEWORK=LAST -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_INSTALL_RPATH=/opt/local/lib -DCMAKE_MAKE_PROGRAM=/usr/bin/make -DCMAKE_MODULE_PATH=/opt/local/share/cmake/Modules -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/opt/local;/usr" -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_POLICY_DEFAULT_CMP0025=NEW -Wno-dev -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_OSX_ARCHITECTURES="x86_64" -DCMAKE_OSX_DEPLOYMENT_TARGET="10.14" -DCMAKE_OSX_SYSROOT="/Library/Developer/CommandLineTools/SDKs/MacOSX10.14.sdk" /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_pdf2htmlex/pdf2htmlex/work/pdf2htmlEX-43e3174cbc 
:info:configure Exit code: 1
:error:configure Failed to configure pdf2htmlex: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
:debug:configure     while executing
:debug:configure "$procedure $targetname"

Any one working on this one?

comment:13 Changed 14 months ago by Dave-Allured (Dave Allured)

Cc: Dave-Allured added
Note: See TracTickets for help on using tickets.