wiki:SierraProblems

macOS Sierra Problems

General Issues

First of all, please read Migration.

Updating MacPorts Base

MacPorts must be re-installed in a version configured for macOS 10.12 Sierra.

Ensure you have Xcode 8.0 or greater installed and selected (e.g. sudo xcode-select -s /Applications/Xcode.app/Contents/Developer), and that you have the command line tools installed (xcode-select --install). You also have to agree to the license by running sudo xcodebuild -license.

Tickets for Broken Ports

#45560
csound @5.16.6: KeyError: 10
#52245
cups-pdf mainly broken on El Capitan OS X 10.11
#53095
gnuplot @5.0.5@ on macOS 10.12.1 doesn't show a wxt terminal persistently
#55247
py27-pyqt4-4.12.1_0+phonon: fatal error: 'abstractaudiooutput.h' file not found
#56996
libgcc45 @4.5.4_15: error: non-local symbol required in directive

#52323
aquaterm fails to build on 10.12 sierra
#52438
lua-luabitop @1.0.2_1 cannot build without setting 'configure.sdkroot' on Sierra
#52559
py27-numpy fresh installation on Sierra fails test
#52661
Gedit error in mac sierra
#53168
python27: Python Frameworks not codesigned in MacOS Sierra
#53305
arm-elf-gcc3 @3.4.6_2: fails on Sierra - - undefined symbols
#53338
ogre @1.7.3_4 fails on Sierra -- "invalid deployment target"
#53376
platypus @4.7 fails to build on Sierra: undeclared identifiers in IconFamily.m
#53573
arm-elf-gcc build failed on Sierra 10.12.2
#53702
arm-none-linux-gnueabi-gcc @2005q3-2: fails on Sierra - Undefined symbols for architecture x86_64
#53759
mplayer binary seems broken on macbook 5,1 running Sierra
#54468
problem installing py36-ipython on Mac OS Sierra 10.12.5
#56297
bind9 @9.12.1_0 does not work on my High Sierra
#56954
py-numpy: numpy.polyfit broken with +gfortran variant on High Sierra
#57067
SIerra: issue with assembler "as" in conjunction with gfortran
#57109
cquery @20180718 shared_timed_mutex introduced in macOS 10.12
#57676
sshfs 2.x unable to create mount points (Sierra/High Sierra and later)
#57879
MacVim @8.1.snapshot153_0+cscope+huge+lua+perl+python27+python36+ruby+ruby18: Error running on High Sierra 10.13.6. The error claims that it can only run on Mojave 10.14
#58063
py37-numpy @1.15.4_0+gfortran+openblas: cannot upgrade to @1.16.1_0 on High Sierra

Last modified 17 months ago Last modified on Sep 27, 2017, 4:38:03 PM