Opened 14 months ago

Closed 12 months ago

Last modified 4 months ago

#52081 closed enhancement (fixed)

Ports should require perl5.24 instead of 5.22

Reported by: mojca (Mojca Miklavec) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: afb@…, blair (Blair Zajac), brucemiller (bruce miller), neverpanic (Clemens Lang), cfaerber@…, chris@…, ctreleaven (Craig Treleaven), dliessi (Davide Liessi), db_macports@…, dbevans (David B. Evans), danielluke (Daniel J. Luke), drkp (Dan Ports), cooljeanius (Eric Gallager), fernando.iazeolla@…, gjasny@…, humem (humem), Ionic (Mihai Moldovan), jmroot (Joshua Root), joefowler (Joe Fowler), nortcele, jonahb (Jonah Burke), juanrgar@…, kurthindenburg (Kurt Hindenburg), kmayer (Ken Mayer), kou@…, mww@…, n3npq@…, openmaintainer@…, pixilla (Bradley Giesbrecht), quentinmit (Quentin Smith), RJVB (René Bertin), ryandesign (Ryan Schmidt), tenomoto (Takeshi Enomoto), tlockhart1976@…, xeron (Ivan Larionov), rod@…
Port: LaTeXML PsyncX ack amavisd-new amttools archway argus-monitor auto-multiple-choice backuppc biblatex-biber bugzilla clearsilver cloc cpan2port cpuid cssh cutter cvsweb cws2fws-pl cyrus-imapd dc3dd ddclient demeter demeter-devel dirvish docbook-utils docbook2X dpkg dvdrip eperl exo extractopinion finch flac2mp3 fntsample ftpsync fusioninventory-agent fwknop get_iplayer ghsum git git-cal glom gnome-bindings-perl5 gnucash gnucash-devel gnumeric gnupod gtk-doc gtkmm help2man hugin-app icon-naming-utils icoutils ikiwiki imageindex imapsync intltool latexdiff liboping liboping-devel libpurple log2timeline magicspp mailqfmt makepasswd mb2md mediaserv metar metasploit2 mod_perl2 monarch moreutils mosh mozjs17 mozjs24 mtn-browse munin muttprint myrepos mysql-zrm mythtv-core.25 mythtv-core.26 mythtv-core.27 mythtv-core.28 mythtv-plugins.27 mythtv-plugins.28 mythweb.25 mythweb.26 mythweb.27 mythweb.28 nagios-plugins naturaldocs nedi net-snmp nfsen nrg openbrowser ossp-uuid pcsc-tools pearl pemail percona-toolkit perfect_maildir perl5 perlprimer pflogsumm pidgin po4a postgresql_autodoc postgrey psh pulseaudio rancid rpm rpm54 rrdtool rsnapshot sendpage shelldap signing-party sleuthkit smokeping snmptt snownews spidereyeballs sqlgrey stow swaks sympa t-prot tablet-encode texinfo thieriot tinyca2 torrentsniff tsung vit wakeonlan wget whois wml xchat-gnome xqf xraylib xserve-raid-tools

Description (last modified by mf2k (Frank Schima))

It's time to move to perl5.24. (See an older ticket #48365.)

The list of ports has been generated with

port info --line --index --name --maintainer depends:'perl5\.22' or depends:'p5\.22-' | grep -v 'p5-' | grep -v 'p5.22-' | sort > list.txt

and might contain errors.

No maintainer

Open maintainer

Maintained

Change History (44)

comment:1 Changed 14 months ago by ctreleaven (Craig Treleaven)

mythweb.28 - r151849

mythtv-core.28, mythtv-plugins.28 - r151852

The 0.28 versions are in testing right now. Assuming no regressions with 5.24, I'll amend my other ports in a few days.

comment:2 Changed 14 months ago by mojca (Mojca Miklavec)

  • Description modified (diff)

nagios-plugins r151875 naturaldocs r151874 nedi r151873 nfsen r151872 nrg r151871 ossp-uuid r151870 pemail r151869 perfect_maildir r151868 perlprimer r151867 pflogsumm r151866 po4a r151865 postgresql_autodoc r151864 postgrey r151863 psh r151862 rancid r151861 rrdtool r151860 sendpage r151859 shelldap r151858 sleuthkit r151857 smokeping r151856 snmptt r151855 snownews r151854 spidereyeballs r151853 stow r151851 swaks r151850 sympa r151848 t-prot r151847 tablet-encode r151846 texinfo r151845 tinyca2 r151844 torrentsniff r151843 tsung r151842 xchat-gnome r151841 xqf r151840 xserve-raid-tools r151839 fntsample r151838

Last edited 14 months ago by mojca (Mojca Miklavec) (previous) (diff)

comment:3 Changed 14 months ago by rod@…

  • Cc rod@… removed

Cc Me!

comment:4 Changed 14 months ago by rod@…

  • Cc rod@… added

Cc Me!

comment:5 follow-up: Changed 14 months ago by RJVB (René Bertin)

Isn't there a stub "perl5" family of dependencies which ports can declare if they don't care about the exact perl version?

comment:6 in reply to: ↑ 5 ; follow-up: Changed 14 months ago by danielluke (Daniel J. Luke)

Replying to rjvbertin@…:

Isn't there a stub "perl5" family of dependencies which ports can declare if they don't care about the exact perl version?

nope.

comment:7 Changed 14 months ago by kurthindenburg (Kurt Hindenburg)

  • Description modified (diff)

comment:8 Changed 14 months ago by mojca (Mojca Miklavec)

  • Description modified (diff)

comment:9 in reply to: ↑ 6 ; follow-up: Changed 14 months ago by RJVB (René Bertin)

Replying to dluke@…:

Replying to rjvbertin@…:

Isn't there a stub "perl5" family of dependencies which ports can declare if they don't care about the exact perl version?

nope.

With all due respect: that sucks. What is/was wrong with port:perl5 and/or port:p5-foo?

comment:10 Changed 14 months ago by dbevans (David B. Evans)

  • Description modified (diff)

comment:11 in reply to: ↑ 9 Changed 14 months ago by raimue (Rainer Müller)

  • Cc raimue@… removed
  • Description modified (diff)

comment:12 Changed 14 months ago by mojca (Mojca Miklavec)

René, the ticket to discuss perl packaging is still at #50000. Let's not spam this ticket (with already too much traffic to too many people) discussing ideas that would even prolong transition to 5.24 and cannot be implemented overnight anyway.

Mihai, I "asked for help" at https://trac.edgewall.org/ticket/2073#comment:30. One way to avoid excessive traffic on tickets like this one (without any further features) might be to:

  • open the second ticket with basically no subscribers (I'm fine being subscribed) and tracking the progress (changing the list of ports, crossing out the ticket numbers and adding revisions that fixed them, ...)
  • a ticket like this one with many subscribers would only contain a pointer to the other ticket and responsible developers would only be notified once, when the ticket gets closed

Feel free to do whatever you find most suitable (additional discussion can happen "off-list/off-ticket" or on IRC).

comment:13 follow-up: Changed 14 months ago by RJVB (René Bertin)

Not that I can commit it anyway, but I had a look at my port:cpuid. Turns out it depends on port:p${perl5.major}-foo ; am I right that this means it'll transition as soon as the perl5.major variable changes?

If not, I'll just make it depend on the p5-foo variants of its 2 dependencies.

Last edited 14 months ago by RJVB (René Bertin) (previous) (diff)

comment:14 in reply to: ↑ 13 Changed 14 months ago by danielluke (Daniel J. Luke)

Replying to rjvbertin@…:

Not that I can commit it anyway, but I had a look at my port:cpuid. Turns out it depends on port:p${perl5.major}-foo ; am I right that this means it'll transition as soon as the perl5.major variable changes?

that's a bad idea - think about the binary archives or the fact that a person's installed files will be different with the same version/revision of a Portfile.

If not, I'll just make it depend on the p5-foo variants of its 2 dependencies.

That's a bad idea for similar reasons as well.

Please follow the standard recommendations for depending on perl/perl modules and discuss improvements in the ticket mentioned earlier in thread (#50000).

comment:15 Changed 14 months ago by dliessi (Davide Liessi)

get_iplayer: see ticket #52105

comment:16 Changed 14 months ago by xeron (Ivan Larionov)

dpkg: ticket #52112

comment:17 Changed 14 months ago by mf2k (Frank Schima)

  • Type changed from update to enhancement

comment:18 Changed 14 months ago by Ionic (Mihai Moldovan)

  • Description modified (diff)

comment:19 Changed 14 months ago by Ionic (Mihai Moldovan)

  • Description modified (diff)

comment:20 Changed 14 months ago by Ionic (Mihai Moldovan)

  • Description modified (diff)

comment:21 Changed 14 months ago by nerdling (Jeremy Lavergne)

  • Cc snc@… removed
  • Description modified (diff)

comment:22 Changed 14 months ago by Ionic (Mihai Moldovan)

  • Description modified (diff)

comment:23 Changed 14 months ago by Ionic (Mihai Moldovan)

  • Description modified (diff)

comment:24 Changed 14 months ago by dbevans (David B. Evans)

  • Description modified (diff)

comment:25 Changed 14 months ago by dbevans (David B. Evans)

  • Description modified (diff)

comment:26 Changed 14 months ago by dbevans (David B. Evans)

  • Description modified (diff)

comment:27 Changed 14 months ago by dbevans (David B. Evans)

  • Description modified (diff)

comment:28 Changed 14 months ago by mkae (Marko Käning)

  • Cc mk@… removed
  • Description modified (diff)

comment:29 Changed 13 months ago by xeron (Ivan Larionov)

ipcalc update to use perl5.24: #52309

comment:30 Changed 13 months ago by mf2k (Frank Schima)

  • Description modified (diff)

comment:31 Changed 13 months ago by ci42

  • Cc ciserlohn@… removed
  • Description modified (diff)

comment:32 Changed 13 months ago by drkp (Dan Ports)

  • Description modified (diff)

comment:33 Changed 13 months ago by drkp (Dan Ports)

  • Description modified (diff)

comment:34 Changed 13 months ago by g5pw (Aljaž Srebrnič)

  • Cc g5pw@… removed
  • Description modified (diff)

comment:35 Changed 12 months ago by tenomoto (Takeshi Enomoto)

magicspp r153821

comment:36 Changed 12 months ago by mf2k (Frank Schima)

  • Description modified (diff)

comment:37 Changed 12 months ago by cfaerber@…

I've uploaded patches for wml and eperl to#52594 and #52595 (no further changes required). Could someone with commit rights update the ports, please?

comment:38 Changed 12 months ago by mf2k (Frank Schima)

  • Description modified (diff)

comment:39 Changed 12 months ago by mojca (Mojca Miklavec)

  • Description modified (diff)

comment:40 Changed 12 months ago by mf2k (Frank Schima)

  • Description modified (diff)

comment:41 Changed 12 months ago by mojca (Mojca Miklavec)

add 5.24 or make sure it is used:

remove 5.22:

pending request:

  • subversion-perlbindings: #52737

comment:42 Changed 12 months ago by mojca (Mojca Miklavec)

Submodules removed in r154393.

comment:43 Changed 12 months ago by mojca (Mojca Miklavec)

  • Resolution set to fixed
  • Status changed from new to closed

comment:44 Changed 4 months ago by mojca (Mojca Miklavec)

Please start testing your ports against perl5.26.

Note: See TracTickets for help on using tickets.