Opened 9 years ago

Closed 9 years ago

Last modified 2 years ago

#31987 closed defect (invalid)

netpbm install tries to fetch nonexistent file

Reported by: nathmclean@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: netpbm

Description (last modified by ryandesign (Ryan Schmidt))

I am trying to install netpbm through macports, however it fails with the message:

Error: Target org.macports.fetch returned: Subversion check out failed

After inspecting the log file (attached) it seems to me the problem lies in that mac ports is trying to fetch the file: netpbm-10.47.31_0.darwin_10.x86_64.tgz from http://packages.macports.org/netpbm/ and gets a 404 error

The actual file at that location is a different type of archive, using the file extension tbz2.

I am new to using MacPorts and I was wondering if there is any quick and dirty way to change the archive MacPorts looks for when I type the command "port install netpbm"

I have just updated MacPorts definitions using "port selfupdate" so it seems to me that this is a bug.

Thanks in advance!

Attachments (1)

main.log (16.7 KB) - added by nathmclean@… 9 years ago.
netpbm install log file

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by nathmclean@…

Attachment: main.log added

netpbm install log file

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: netpbm added

comment:2 in reply to:  description Changed 9 years ago by ryandesign (Ryan Schmidt)

Yes, MacPorts tries to download pre-built archives from packages.macports.org. No, it is not a problem if a package is not found there; in that case, MacPorts will try to download the source code and compile it on your system. In your case, the problem is that downloading the source code from netpbm's repository failed, for an unknown reason (perhaps #29692).

Yes, we only publish .tbz2 archives on packages.macports.org. For some reason your MacPorts is set to use .tgz archives. Perhaps you originally installed MacPorts a long time ago, when that was the default archive type. I recommend you edit /opt/local/etc/macports/macports.conf and change portarchivetype to tbz2, or better yet just comment out that line so it uses the default (tbz2). Many other settings in macports.conf have changed since the days when tgz was the default archive type, so you should spend some time comparing macports.conf with macports.conf.default in the same directory, and adopt any changes from macports.conf.default that you haven't deliberately changed.

comment:3 Changed 9 years ago by nathmclean@…

Thank you very much. It worked fine after I changed the config file and cleaned netpbm.

comment:4 Changed 9 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed

comment:5 Changed 2 years ago by ryandesign (Ryan Schmidt)

In 9192b329cc13ddda097b50a8cb086adc4b8d5435/macports-ports:

netpbm: Fetch from GitHub mirror instead of SourceForge svn

Fetching from svn has been repeatedly problematic.

See: #28250
See: #28590
See: #29692
See: #31987
See: #32000
See: #36517
See: #38823
See: #41023
See: #48687
See: #50087
See: #54428
See: #54918
See: #54919
See: #54924
See: #55853
See: #55930
See: #55986

Note: See TracTickets for help on using tickets.