Opened 8 years ago

Closed 7 years ago

Last modified 15 months ago

#32000 closed defect (worksforme)

netpbm: could not connect to server (https://netpbm.svn.sourceforge.net)

Reported by: sonny@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: calsaiwing@…
Port: netpbm

Description (last modified by ryandesign (Ryan Schmidt))

main.log

:msg:main --->  Computing dependencies for netpbm:info:main .:debug:main Searching for dependency: subversion
:debug:main Found Dependency: receipt exists for subversion
:debug:main Searching for dependency: perl5
:debug:main Found Dependency: receipt exists for perl5
:debug:main Searching for dependency: zlib
:debug:main Found Dependency: receipt exists for zlib
:debug:main Searching for dependency: jpeg
:debug:main Found Dependency: receipt exists for jpeg
:debug:main Searching for dependency: tiff
:debug:main Found Dependency: receipt exists for tiff
:debug:main Searching for dependency: libpng
:debug:main Found Dependency: receipt exists for libpng
:debug:main Searching for dependency: jasper
:debug:main Found Dependency: receipt exists for jasper
:debug:main Searching for dependency: jbigkit
:debug:main Found Dependency: receipt exists for jbigkit
:debug:main Searching for dependency: libxml2
:debug:main Found Dependency: receipt exists for libxml2
:msg:main 
:debug:main Executing org.macports.main (netpbm)
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 505
:debug:main euid changed to: 505
:debug:archivefetch archivefetch phase started at Wed Nov  9 12:34:11 MST 2011
:msg:archivefetch --->  Fetching archive for netpbm
:debug:archivefetch Executing org.macports.archivefetch (netpbm)
:debug:archivefetch euid/egid changed to: 0/0
:debug:archivefetch chowned /usr/lanl/var/macports/software/netpbm to macports
:debug:archivefetch euid/egid changed to: 505/505
:debug:archivefetch euid/egid changed to: 0/0
:debug:archivefetch chowned /usr/lanl/var/macports/incoming to macports
:debug:archivefetch euid/egid changed to: 505/505
:info:archivefetch --->  netpbm-10.47.31_0.darwin_9.i386.tbz2 doesn't seem to exist in /usr/lanl/var/macports/software/netpbm
:debug:archivefetch Privilege de-escalation not attempted as not running as root.
:debug:fetch fetch phase started at Wed Nov  9 12:34:12 MST 2011
:notice:fetch --->  Fetching netpbm
:debug:fetch euid/egid changed to: 0/0
:debug:fetch chowned /usr/lanl/var/macports/distfiles/netpbm to macports
:debug:fetch euid/egid changed to: 505/505
:debug:fetch Executing org.macports.fetch (netpbm)
:debug:fetch Environment: CPATH='/usr/lanl/include' CC_PRINT_OPTIONS_FILE='/usr/lanl/var/macports/build/_usr_lanl_var_macports_sources_rsync.macports.org_release_ports_graphics_netpbm/netpbm/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/usr/lanl/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.5'
:debug:fetch Assembled command: 'cd "/usr/lanl/var/macports/build/_usr_lanl_var_macports_sources_rsync.macports.org_release_ports_graphics_netpbm/netpbm/work" && /usr/lanl/bin/svn --non-interactive --trust-server-cert export https://netpbm.svn.sourceforge.net/svnroot/netpbm/stable@1592'
:debug:fetch Executing command line:  cd "/usr/lanl/var/macports/build/_usr_lanl_var_macports_sources_rsync.macports.org_release_ports_graphics_netpbm/netpbm/work" && /usr/lanl/bin/svn --non-interactive --trust-server-cert export https://netpbm.svn.sourceforge.net/svnroot/netpbm/stable@1592 2>&1
:info:fetch svn: warning: W000013: Can't open file '/Users/sonny/.subversion/servers': Permission denied
:info:fetch svn: E175002: Unable to connect to a repository at URL 'https://netpbm.svn.sourceforge.net/svnroot/netpbm/stable'
:info:fetch svn: E175002: OPTIONS of 'https://netpbm.svn.sourceforge.net/svnroot/netpbm/stable': could not connect to server (https://netpbm.svn.sourceforge.net)
:info:fetch shell command " cd "/usr/lanl/var/macports/build/_usr_lanl_var_macports_sources_rsync.macports.org_release_ports_graphics_netpbm/netpbm/work" && /usr/lanl/bin/svn --non-interactive --trust-server-cert export https://netpbm.svn.sourceforge.net/svnroot/netpbm/stable@1592 2>&1" returned error 1
:error:fetch Target org.macports.fetch returned: Subversion check out failed
:debug:fetch Backtrace: Subversion check out failed
    while executing
"svnfetch"
    ("svn" arm line 1)
    invoked from within
"switch -- "${fetch.type}" {
        bzr     { return [bzrfetch] }
        cvs     { return [cvsfetch] }
        svn     { return [svnfetch] }
        ..."
    (procedure "portfetch::fetch_main" line 10)
    invoked from within
"$procedure $targetname"
:info:fetch Warning: the following items did not execute (for netpbm): org.macports.install org.macports.fetch org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot
:notice:fetch Log for netpbm is at: /usr/lanl/var/macports/logs/_usr_lanl_var_macports_sources_rsync.macports.org_release_ports_graphics_netpbm/netpbm/main.log

Change History (7)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: servers Permission Denied removed
Summary: netpbm fails to installnetpbm: could not connect to server (https://netpbm.svn.sourceforge.net)

Has duplicate #32001.

Looks like previous netpbm fetch failure tickets which have been closed as temporary issues. Try again later?

comment:2 in reply to:  1 Changed 8 years ago by sonny@…

Replying to ryandesign@…:

Has duplicate #32001.

Looks like previous netpbm fetch failure tickets which have been closed as temporary issues. Try again later?

Tried again today and received the same failure, could this be an issue? ":info:fetch svn: warning: W000013: Can't open file '/Users/username/.subversion/servers': Permission denied"

comment:3 Changed 8 years ago by calsaiwing@…

Cc: calsaiwing@… added

Cc Me!

comment:4 in reply to:  description ; Changed 8 years ago by calsaiwing@…

seems to work now.

comment:5 in reply to:  4 Changed 8 years ago by stfo@…

Replying to calsaiwing@…:

seems to work now.

No, it doesn't work at all...

comment:6 Changed 7 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

Can't reproduce.

comment:7 Changed 15 months ago by ryandesign (Ryan Schmidt)

In 9192b329cc13ddda097b50a8cb086adc4b8d5435/macports-ports:

netpbm: Fetch from GitHub mirror instead of SourceForge svn

Fetching from svn has been repeatedly problematic.

See: #28250
See: #28590
See: #29692
See: #31987
See: #32000
See: #36517
See: #38823
See: #41023
See: #48687
See: #50087
See: #54428
See: #54918
See: #54919
See: #54924
See: #55853
See: #55930
See: #55986

Note: See TracTickets for help on using tickets.