Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#48687 closed defect (invalid)

libnetpbm: fetch fails on El Capitan beta

Reported by: smaret (Sebastien Maret) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: libnetbm

Description (last modified by smaret (Sebastien Maret))

libnetpbm installation on El Capitan beta fails with the following message:

--->  Fetching distfiles for libnetpbm
Error: org.macports.fetch for port libnetpbm returned: can't read "proxy_host": no such variable
Error: Failed to install libnetpbm

This seems to be a different error than #48600.

Attachments (1)

libnetpbm_main.log (1.9 KB) - added by smaret (Sebastien Maret) 5 years ago.
Log file for port libnetpbm

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by smaret (Sebastien Maret)

Attachment: libnetpbm_main.log added

Log file for port libnetpbm

comment:1 Changed 5 years ago by smaret (Sebastien Maret)

Description: modified (diff)

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…

I can't reproduce this.

Is proxy_host set in macports.conf? If so, to what value?

comment:3 in reply to:  2 Changed 5 years ago by smaret (Sebastien Maret)

Replying to ryandesign@…:

Is proxy_host set in macports.conf? If so, to what value?

Not it wasn't. However, I had the HTTP_PROXY and HTTPS_PROXY environnement variables set to empty strings . Unsetting these variables solved the problem.

Thanks for the hint!

comment:4 Changed 5 years ago by smaret (Sebastien Maret)

Resolution: fixed
Status: newclosed

comment:5 in reply to:  4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

Replying to smaret@…:

Actually we didn't fix anything; it was an invalid user configuration.

comment:6 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: reopenedclosed

comment:7 Changed 2 years ago by ryandesign (Ryan Schmidt)

In 9192b329cc13ddda097b50a8cb086adc4b8d5435/macports-ports:

netpbm: Fetch from GitHub mirror instead of SourceForge svn

Fetching from svn has been repeatedly problematic.

See: #28250
See: #28590
See: #29692
See: #31987
See: #32000
See: #36517
See: #38823
See: #41023
See: #48687
See: #50087
See: #54428
See: #54918
See: #54919
See: #54924
See: #55853
See: #55930
See: #55986

Note: See TracTickets for help on using tickets.